Package: kmymoney
Version: 4.5-1
Severity: important

With KMyMoney 3.98.1-2 and previous versions online banking did work
as expected. But with KMyMoney 4.5-1 the menu entries for getting
current balances via HBCI are greyed out. And the libraries in
question are no longer in the dependencies:

shambhala:~> apt-cache show kmymoney | egrep "(Version|Depends)"             
Version: 4.5-1
Depends: kdebase-runtime, kdepim-runtime, libc6 (>= 2.3.6-6~), libgcc1 (>= 
1:4.1.1), libgpgme++2 (>= 4:4.4.4), libical0 (>= 0.30), libkabc4 (>= 4:4.4.4), 
libkdecore5 (>= 4:4.4.4-2~), libkdeui5 (>= 4:4.4.4), libkfile4 (>= 4:4.4.4), 
libkholidays4 (>= 4:4.4.4), libkhtml5 (>= 4:4.4.4), libkio5 (>= 4:4.4.4), 
libkutils4 (>= 4:4.4.4), libofx4, libqt4-dbus (>= 4:4.5.3), libqt4-network (>= 
4:4.5.3), libqt4-sql (>= 4:4.5.3), libqt4-svg (>= 4:4.5.3), libqt4-xml (>= 
4:4.5.3), libqtcore4 (>= 4:4.6.1), libqtgui4 (>= 4:4.6.1), libstdc++6 (>= 
4.4.0), kmymoney-common (= 4.5-1)
Version: 3.98.1-2
Depends: kdebase-runtime, kdepim-runtime, libaqbanking29 (>= 4.0.0), libc6 (>= 
2.3.6-6~), libgcc1 (>= 1:4.1.1), libgpgme++2 (>= 4:4.4.4), libgwenhywfar47 (>= 
3.1.0), libical0 (>= 0.30), libkabc4 (>= 4:4.4.4), libkde3support4 (>= 
4:4.4.4), libkdecore5 (>= 4:4.4.4), libkdeui5 (>= 4:4.4.4), libkfile4 (>= 
4:4.4.4), libkholidays4 (>= 4:4.4.4), libkhtml5 (>= 4:4.4.4), libkio5 (>= 
4:4.4.4), libkutils4 (>= 4:4.4.4), libofx4, libq4banking1, libqt4-dbus (>= 
4:4.5.3), libqt4-qt3support (>= 4:4.5.3), libqt4-sql (>= 4:4.5.3), libqt4-svg 
(>= 4:4.5.3), libqt4-xml (>= 4:4.5.3), libqtcore4 (>= 4:4.6.1), libqtgui4 (>= 
4:4.6.1), libstdc++6 (>= 4.4.0), kmymoney-common (= 3.98.1-2)

libaqbanking29, libgwenhywfar47 and libq4banking1 are completely missing.
Has KMyMoney 4.5 been compiled without them?

I have them still installed:

shambhala:~> apt-show-versions | egrep "(gwenhywfar|banking)"
aqbanking-tools/squeeze uptodate 4.2.4-2
libaqbanking-data/squeeze uptodate 4.2.4-2
libaqbanking-plugins-libgwenhywfar47/squeeze uptodate 4.2.4-2
libaqbanking29/squeeze uptodate 4.2.4-2
libaqbanking29-plugins/squeeze uptodate 4.2.4-2
libaqbanking29-plugins-qt/squeeze uptodate 4.2.4-2
libgwenhywfar47/squeeze uptodate 3.11.3-1
libqbanking8/squeeze uptodate 4.2.4-2

There is no notice of a change in changelog.

It has been several times already that an upgrade of KMyMoney broke online
banking. I wish upgrading was more reliable. I know its in experimental,
but from the posting in debian-kde I thought the only reason was that
its not going into Squeeze - which I find a pity.

Will downgrade now and hope that this fixes online banking.

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (450, 'testing'), (400, 'unstable'), (101, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 2.6.33.7-tp42-toi-3.1.1.1-05125-ga817cb9 (PREEMPT)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages kmymoney depends on:
ii  kdebase-runtime               4:4.4.5-1  runtime components from the offici
ii  kdepim-runtime                4:4.4.5-1  Runtime components for akonadi-kde
ii  kmymoney-common               4.5-1      KMyMoney architecture independent 
ii  libc6                         2.11.2-2   Embedded GNU C Library: Shared lib
ii  libgcc1                       1:4.4.4-8  GCC support library
ii  libgpgme++2                   4:4.4.5-1  c++ wrapper library for gpgme
ii  libical0                      0.44-3     iCalendar library implementation i
ii  libkabc4                      4:4.4.5-1  library for handling address book 
ii  libkdecore5                   4:4.4.5-1  the KDE Platform Core Library
ii  libkdeui5                     4:4.4.5-1  the KDE Platform User Interface Li
ii  libkfile4                     4:4.4.5-1  the File Selection Dialog Library 
ii  libkholidays4                 4:4.4.5-1  holidays calculation library
ii  libkhtml5                     4:4.4.5-1  the KHTML Web Content Rendering En
ii  libkio5                       4:4.4.5-1  the Network-enabled File Managemen
ii  libkutils4                    4:4.4.5-1  various utility classes for the KD
ii  libofx4                       1:0.9.0-3  library to support Open Financial 
ii  libqt4-dbus                   4:4.6.3-1  Qt 4 D-Bus module
ii  libqt4-network                4:4.6.3-1  Qt 4 network module
ii  libqt4-sql                    4:4.6.3-1  Qt 4 SQL module
ii  libqt4-svg                    4:4.6.3-1  Qt 4 SVG module
ii  libqt4-xml                    4:4.6.3-1  Qt 4 XML module
ii  libqtcore4                    4:4.6.3-1  Qt 4 core module
ii  libqtgui4                     4:4.6.3-1  Qt 4 GUI module
ii  libstdc++6                    4.4.4-8    The GNU Standard C++ Library v3

kmymoney recommends no packages.

kmymoney suggests no packages.

-- no debconf information



_______________________________________________
pkg-kde-extras mailing list
pkg-kde-extras@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-kde-extras

Reply via email to