Package: kile
Version: 1:2.1.0~svn1112278beta4-2ubuntu2
Severity: normal
Tags: patch
User: ubuntu-de...@lists.ubuntu.com
Usertags: origin-ubuntu natty ubuntu-patch

See https://bugs.launchpad.net/ubuntu/+source/kile/+bug/577595
Installing kile tries to install enormous amount of packages (installed size
1.4 G!!) when --no-install-recommends installs only 80M on a ~clean Kubuntu
10.04.

The attached Diff was applied to the Kubuntu package to reduce the
dependencies.


*** kile.diff
diff -Nru kile-2.1.0~svn2010122beta5/debian/control 
kile-2.1.0~svn2010122beta5/debian/control
--- kile-2.1.0~svn2010122beta5/debian/control   2011-05-01 19:03:12.000000000 
+0200
+++ kile-2.1.0~svn2010122beta5/debian/control   2011-05-06 15:10:30.000000000 
+0200
@@ -13,12 +14,11 @@
 Package: kile
 Architecture: any
 Depends: ${shlibs:Depends}, ${misc:Depends},
- konsole, texlive-base-bin, texlive-latex-base
-Recommends: asymptote, context, dblatex, dvipdfmx, dvipng, ghostscript,
- imagemagick, kbibtex | pybliographer | gbib | jabref, latex2html, lilypond,
- okular | evince | gv, psutils, tex4ht, texlive-metapost, texlive-xetex,
- www-browser, zip
-Suggests: kile-doc, kile-i18n, texlive-doc-base,
+ konsole, texlive-latex-base
+Recommends: texlive, dvipng, ghostscript, imagemagick, psutils
+Suggests: asymptote, context, dblatex, latex2html,
+ tex4ht, texlive-xetex, lilypond, zip,
+ kile-doc, texlive-doc-base,
  aspell | ispell | hspell
 Conflicts: ktexmaker2 (<< 1.8)
 Replaces: ktexmaker2 (<< 1.8)


-- System Information:
Debian Release: squeeze/sid
  APT prefers oneiric-updates
  APT policy: (500, 'oneiric-updates'), (500, 'oneiric-security'), (500, 
'oneiric-proposed'), (500, 'natty-updates'), (500, 'natty-security'), (500, 
'natty-backports'), (500, 'natty'), (100, 'oneiric-backports'), (50, 
'natty-proposed')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.38-8-generic (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8) (ignored: LC_ALL 
set to en_US.UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages kile depends on:
ii  kdebase-runtime    4:4.6.3-0ubuntu1~ppa2 runtime components from the offici
ii  konsole            4:4.6.3-0ubuntu1~ppa1 X terminal emulator
ii  libc6              2.13-0ubuntu13        Embedded GNU C Library: Shared lib
ii  libgcc1            1:4.5.2-8ubuntu4      GCC support library
ii  libkdecore5        4:4.6.3-0ubuntu1~ppa3 the KDE Platform Core Library
ii  libkdeui5          4:4.6.3-0ubuntu1~ppa3 the KDE Platform User Interface Li
ii  libkfile4          4:4.6.3-0ubuntu1~ppa3 the File Selection Dialog Library 
ii  libkhtml5          4:4.6.3-0ubuntu1~ppa3 the KHTML Web Content Rendering En
ii  libkio5            4:4.6.3-0ubuntu1~ppa3 the Network-enabled File Managemen
ii  libkparts4         4:4.6.3-0ubuntu1~ppa3 the Framework for the KDE Platform
ii  libkrosscore4      4:4.6.3-0ubuntu1~ppa3 the Kross Core Library
ii  libktexteditor4    4:4.6.3-0ubuntu1~ppa3 the KTextEditor interfaces for the
ii  libqt4-dbus        4:4.7.2-0ubuntu6      Qt 4 D-Bus module
ii  libqtcore4         4:4.7.2-0ubuntu6      Qt 4 core module
ii  libqtgui4          4:4.7.2-0ubuntu6      Qt 4 GUI module
ii  libstdc++6         4.5.2-8ubuntu4        The GNU Standard C++ Library v3
ii  texlive-latex-base 2009-11               TeX Live: Basic LaTeX packages

Versions of packages kile recommends:
ii  dvipng                1.13-1             convert DVI files to PNG graphics
ii  ghostscript           9.01~dfsg-1ubuntu5 interpreter for the PostScript lan
ii  imagemagick           7:6.6.2.6-1ubuntu4 image manipulation programs
ii  psutils               1.17-28            A collection of PostScript documen
ii  texlive               2009-11            TeX Live: A decent selection of th

Versions of packages kile suggests:
ii  aspell                       0.60.6-6    GNU Aspell spell-checker
pn  asymptote                    <none>      (no description available)
pn  context                      <none>      (no description available)
ii  dblatex                      0.3-2       Produces DVI, PostScript, PDF docu
ii  hspell                       1.1-1       Hebrew spell checker and morpholog
pn  kile-doc                     <none>      (no description available)
pn  latex2html                   <none>      (no description available)
pn  lilypond                     <none>      (no description available)
pn  tex4ht                       <none>      (no description available)
ii  texlive-doc-base             2009-2      TeX Live: TeX Live documentation
pn  texlive-xetex                <none>      (no description available)
ii  zip                          3.0-3build1 Archiver for .zip files

-- no debconf information



_______________________________________________
pkg-kde-extras mailing list
pkg-kde-extras@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-kde-extras

Reply via email to