Your message dated Sat, 28 May 2011 16:18:09 +0000
with message-id <e1qqmdj-0002jj...@franck.debian.org>
and subject line Bug#621431: fixed in kdesvn 1.5.5-3
has caused the Debian Bug report #621431,
regarding Still uses libdb4.8
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
621431: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=621431
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: kdesvn
Version: 1.5.5-2
Severity: normal
User: pkg-db-de...@lists.alioth.debian.org
Usertags: db5.1

Your package currently still uses Berkeley DB version 4.8 (libdb4.8).

However, there is a newer Berkeley DB version in the archive (libdb5.1),
with a compatible API.  Berkeley DB version 4.8 will be eventually
removed from unstable in favor of version 5.1.

Please port your package to libdb5.1 as soon as possible.  In most cases
only change required is to update build depends from libdb4.8-dev
to libdb-dev, or just recompile the package.

More complicated scenarios:

- Package does check for DB_VERSION_MAJOR == 4 - this should be updated
  to (DB_VERSION_MAJOR > 4) || ((DB_VERSION_MAJOR == 4) && (DB_VERSION_MINOR >= 
XX)).

- Configure checks - sometime there is a list of db-4.8 db-4.6 db-4.2, etc., 
this
  needs to be updated to just db (or db-5.1 db-5 db), or at least list the 'db'
  in the front

You can see example patch in cyrus-imapd-2.2:
http://git.debian.org/?p=pkg-cyrus-imapd/cyrus-imapd-2.2.git;a=blob;f=debian/patches/99-berkelydb-5.1.dpatch;hb=HEAD

- The packages which use Berkeley DB transactional mode need to upgrade
  the database files before the upgrade.  This is fairly straightforward
  and is well documented on the Berkeley DB website.  But you probably
  already know that because it's not the first Berkeley DB transition.

The example script can be found in the cyrus-imapd-2.4 (not yet released):
http://git.debian.org/?p=pkg-cyrus-imapd/cyrus-imapd-2.4.git;a=blob;f=debian/cyrus-upgrade-db;hb=HEAD

Thanks, 
--
Ondřej Surý <ond...@debian.org>

-- System Information:
Debian Release: squeeze/sid
  APT prefers maverick-updates
  APT policy: (500, 'maverick-updates'), (500, 'maverick-security'), (500, 
'maverick-proposed'), (500, 'maverick-backports'), (500, 'maverick')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.35-28-generic (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash



--- End Message ---
--- Begin Message ---
Source: kdesvn
Source-Version: 1.5.5-3

We believe that the bug you reported is fixed in the latest version of
kdesvn, which is due to be installed in the Debian FTP archive:

kdesvn-dbg_1.5.5-3_i386.deb
  to main/k/kdesvn/kdesvn-dbg_1.5.5-3_i386.deb
kdesvn-kio-plugins_1.5.5-3_i386.deb
  to main/k/kdesvn/kdesvn-kio-plugins_1.5.5-3_i386.deb
kdesvn_1.5.5-3.debian.tar.gz
  to main/k/kdesvn/kdesvn_1.5.5-3.debian.tar.gz
kdesvn_1.5.5-3.dsc
  to main/k/kdesvn/kdesvn_1.5.5-3.dsc
kdesvn_1.5.5-3_i386.deb
  to main/k/kdesvn/kdesvn_1.5.5-3_i386.deb
libsvnqt-dev_1.5.5-3_i386.deb
  to main/k/kdesvn/libsvnqt-dev_1.5.5-3_i386.deb
libsvnqt6_1.5.5-3_i386.deb
  to main/k/kdesvn/libsvnqt6_1.5.5-3_i386.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 621...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Michael Biebl <bi...@debian.org> (supplier of updated kdesvn package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Sat, 28 May 2011 17:21:39 +0200
Source: kdesvn
Binary: libsvnqt6 libsvnqt-dev kdesvn kdesvn-kio-plugins kdesvn-dbg
Architecture: source i386
Version: 1.5.5-3
Distribution: unstable
Urgency: low
Maintainer: Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org>
Changed-By: Michael Biebl <bi...@debian.org>
Description: 
 kdesvn     - Subversion client with tight KDE integration
 kdesvn-dbg - debug symbols for kdesvn
 kdesvn-kio-plugins - Subversion I/O slaves for KDE
 libsvnqt-dev - Qt wrapper library for Subversion (development files)
 libsvnqt6  - Qt wrapper library for Subversion
Closes: 621431 628325
Changes: 
 kdesvn (1.5.5-3) unstable; urgency=low
 .
   * debian/patches/doctype_version.patch
     - Bump DOCTYPE version to 4.2 to fix FTBFS with kdoctools 4.6.
       Patch taken from Kubuntu. Closes: #628325
   * Bump Standards-Version to 3.9.2. No further changes.
   * Build against newer apr-util to get rid of the libdb4.8 dependency.
     Closes: #621431
Checksums-Sha1: 
 019f6258fd73d8d49d0dd65faefe3c2404e57a2b 2043 kdesvn_1.5.5-3.dsc
 41c436ed143884c021b8ac0dcb44d578e1754089 12926 kdesvn_1.5.5-3.debian.tar.gz
 db6ffae9349b5915c21e7d39235726eddc874df1 200054 libsvnqt6_1.5.5-3_i386.deb
 fed4b43db5623fbf9b53bf20e7ddc579e852e9ee 46338 libsvnqt-dev_1.5.5-3_i386.deb
 5479b254e526481c089cec7b4bf6022cc6ecb16c 2156318 kdesvn_1.5.5-3_i386.deb
 dfb0a49178eb126179e9c8322278f14b668672bb 223932 
kdesvn-kio-plugins_1.5.5-3_i386.deb
 8e60a0eec5d6b6de7a0b050a30e08d8e5d5cdff6 9629728 kdesvn-dbg_1.5.5-3_i386.deb
Checksums-Sha256: 
 960b0e59743236638caa14fc50630aaa10a638c232133b593b0a7c7368f367a3 2043 
kdesvn_1.5.5-3.dsc
 4ab946041cda9397df59960ede16f0670e0ddef700069b33effdcc148468980a 12926 
kdesvn_1.5.5-3.debian.tar.gz
 99a6b522967d224cbb993eaf00dafbd8a32d279496d5302e37761f30e835d9c7 200054 
libsvnqt6_1.5.5-3_i386.deb
 00aa4cc02477a4497a35bf6015b842f7b1b8a6d6870c304e421f0f222106e3ba 46338 
libsvnqt-dev_1.5.5-3_i386.deb
 c922fc32422d677ce041b98686cc9189ba6b11c362758e3af4d0cbe152f8fc3a 2156318 
kdesvn_1.5.5-3_i386.deb
 5b723047c9cab37f63f53675f0c8bd961e24d5d6f71fa603b5360eef949456cf 223932 
kdesvn-kio-plugins_1.5.5-3_i386.deb
 19960231302c29f0e8d81ea0e3c5073fd44a22618fcb8d75283fde998142aae3 9629728 
kdesvn-dbg_1.5.5-3_i386.deb
Files: 
 c6792da24e0ee4ad90d17cbcb6d3d965 2043 vcs optional kdesvn_1.5.5-3.dsc
 f8a4172da689333eae0c8d1f90a937c8 12926 vcs optional 
kdesvn_1.5.5-3.debian.tar.gz
 51acc7c2c7774829a992eafd8583fbf4 200054 libs optional 
libsvnqt6_1.5.5-3_i386.deb
 652d5c9c6cb5e9285ae23272fa480cde 46338 libdevel optional 
libsvnqt-dev_1.5.5-3_i386.deb
 48f3cac31a35d005396ead1ee151cb84 2156318 vcs optional kdesvn_1.5.5-3_i386.deb
 08d76368c26516de5f60f4251cdcae41 223932 vcs optional 
kdesvn-kio-plugins_1.5.5-3_i386.deb
 0fe30d46467a754f684883aad0c1beb1 9629728 debug extra 
kdesvn-dbg_1.5.5-3_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iQIcBAEBCAAGBQJN4RZpAAoJEGrh3w1gjyLcO9kP/i9xW5fVRNi6jSZHXRGkYKT7
M7G29gGk7ypxtpAkMO0EjQ6lHq94IUDQv/rCPgEP+/DS8YT+Cr9iNjj2gtL6Q/Lh
aTgEiwMIEnJGomGvoFeh2eGzAlCSm4fSFRBs+2Ae5Usq31sI5mf/SXOhspLU7n57
28Teymt560rIXt9+cJ1R5TY2R6ZC+WOb2BZevY0xDiJdPAgR3XuNY8rTS9bG0U2T
lfnSWingC0VEDgGVVPa+BmeXX9m1r2l/p223AwhTYBGCcFNnYsAUCrAgOICD3s+7
niAlhRyXcHneGRjbWjFSrWQF2V4cek9jDEMgTf+U2GaScqTLjb5eycNFd9KEc7D5
/9yixFX5JSjiXyW0bleZ4NO04gWQwIBC/tAbDaCLnwWWjgzY1ysJGHT4UhXkFMDm
55qWYsenknWPaaUET18C5FKVsGPsZkkVl/PAAGkQv+ItIfCJFGfeGOqZiZ3hEkqd
s46ApY00AnNM+XM0R5TbLGhCLK2hP3VK0SlMzbekDZUxJJ9XeD45faAXw7u4mQdG
f7ALeN3zM677i0gSClQnUj5WUS7U5QwboCyePmqXs+/b3OTQIPzIe8VFZyyWz83r
tZ975wamCh9YYfkX6FB4yJRIK17N03zU4rGHu10if0f4obXy3hywKxI1eAUBpfbH
ElgyprmW55TEsn1NeTLO
=ueSr
-----END PGP SIGNATURE-----



--- End Message ---
_______________________________________________
pkg-kde-extras mailing list
pkg-kde-extras@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-kde-extras

Reply via email to