Package: smb4k
Version: 0.10.10-1
Severity: grave
Tags: patch
User: debian-...@lists.debian.org
Usertags: kfreebsd

smb4k is uninstallable on kfreebsd-amd64 because of its dependency on smbfs.

On GNU/kFreeBSD, the functionality for "mount -t smbfs" is provided by
freebsd-smbfs package instead.

Please consider attached patch to fix this problem.  I've verified that
smb4k interacts correctly with this package (using smb4k_mount command)
once the dependency has been adjusted.

-- System Information:
Debian Release: 6.0.3
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable')
Architecture: kfreebsd-amd64 (x86_64)

Kernel: kFreeBSD 8.1-1-amd64
Locale: LANG=ca_AD.UTF-8, LC_CTYPE=ca_AD.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
=== modified file 'debian/control'
--- debian/control      2011-11-26 20:50:02 +0000
+++ debian/control      2011-11-26 20:50:58 +0000
@@ -11,10 +11,10 @@ Vcs-Svn: svn://svn.debian.org/pkg-kde/kd
 Vcs-Browser: http://svn.debian.org/wsvn/pkg-kde/kde-extras/smb4k/trunk/
 
 Package: smb4k
-Architecture: any
+Architecture: linux-any kfreebsd-any
 Depends: ${shlibs:Depends}, ${misc:Depends},
  samba-common-bin (>= 2:3.4.7~dfsg), smbclient (>= 2:3.4.7~dfsg),
- smbfs (>= 2:4.1)
+ smbfs (>= 2:4.1) [linux-any] | freebsd-smbfs [kfreebsd-any]
 Recommends: sudo
 Suggests: kwalletmanager
 Description: Samba (SMB) share advanced browser for KDE

_______________________________________________
pkg-kde-extras mailing list
pkg-kde-extras@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-kde-extras

Reply via email to