Package: kde-config-touchpad
Version: 0.8.1-1
Severity: important

After installing kde-config-touchpad I tried to use it but it crashes because 
of ImportError:

% kcmshell4 kcm_synaptiks
kcmshell(11730)/python (plugin): Failed to import module 
Traceback (most recent call last):
  File "/usr/share/kde4/apps/synaptiks/", line 39, in <module>
    from synaptiks.kde.widgets.kcm import make_kcm_widget
  File "/usr/lib/python2.6/dist-packages/synaptiks/kde/", line 39, 
in <module>
    from PyKDE4.kdecore import KAboutData, ki18nc
ImportError: cannot open shared object file: No such file 
or directory
kcmshell(11730)/python (plugin): Failed to import module 
kcmshell(11730)/kcontrol KCModuleLoader::loadModule: This module has no valid 
entry symbol at all. The reason could be that it's still using 
KDE-FactoryName which is not supported anymore 

If I run:

# apt-get install libpython2.6

...then "kcmshell4 kcm_synaptiks" works perfectly because libpython2.6 contains

-- System Information:
Debian Release: wheezy/sid
  APT prefers testing
  APT policy: (500, 'testing'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 3.1.0-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages kde-config-touchpad depends on:
ii  libxi6                2:1.4.5-1
ii  python                2.7.2-10
ii  python-kde4           4:4.6.80-3+b2
ii  python-pkg-resources  0.6.24-1
ii  python-pyudev         0.13-1
ii  python-qt4            4.9-2
ii  python2.6             2.6.7-4
ii  python2.7             2.7.2-8

Versions of packages kde-config-touchpad recommends:
ii  libxtst6     2:1.2.0-4
ii  python-dbus  0.84.0-3
ii  upower       0.9.15-1

kde-config-touchpad suggests no packages.

-- no debconf information

pkg-kde-extras mailing list

Reply via email to