Your message dated Fri, 11 May 2012 17:17:38 +0000
with message-id <e1ssttg-0002qi...@franck.debian.org>
and subject line Bug#669163: fixed in apt 0.9.3
has caused the Debian Bug report #669163,
regarding qapt FTBFS MD5Summation and debMD5 undeclared
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
669163: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=669163
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: qapt
Version: 1.3.0-1

from the armel build log

cd /build/buildd-qapt_1.3.0-1+b1-armel-vECdlq/qapt-1.3.0/obj-arm-linux-gnueabi/src 
&& /usr/bin/c++   -Dqapt_EXPORTS -g -O2 -fstack-protector 
--param=ssp-buffer-size=4 -Wformat -Wformat-security -Werror=format-security  
-std=c++0x -fno-threadsafe-statics -fvisibility=hidden -fvisibility-inlines-hidden 
-fPIC -I/build/buildd-qapt_1.3.0-1+b1-armel-vECdlq/qapt-1.3.0 
-I/build/buildd-qapt_1.3.0-1+b1-armel-vECdlq/qapt-1.3.0/obj-arm-linux-gnueabi 
-I/usr/include/qt4 -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtDBus 
-I/usr/include/polkit-qt-1 -I/build/buildd-qapt_1.3.0-1+b1-armel-vECdlq/qapt-1.3.0/src 
-I/build/buildd-qapt_1.3.0-1+b1-armel-vECdlq/qapt-1.3.0/obj-arm-linux-gnueabi/src    -o 
CMakeFiles/qapt.dir/debfile.o -c 
/build/buildd-qapt_1.3.0-1+b1-armel-vECdlq/qapt-1.3.0/src/debfile.cpp
/build/buildd-qapt_1.3.0-1+b1-armel-vECdlq/qapt-1.3.0/src/debfile.cpp: In 
member function 'QByteArray QApt::DebFile::md5Sum() const':
/build/buildd-qapt_1.3.0-1+b1-armel-vECdlq/qapt-1.3.0/src/debfile.cpp:187:5: 
error: 'MD5Summation' was not declared in this scope
/build/buildd-qapt_1.3.0-1+b1-armel-vECdlq/qapt-1.3.0/src/debfile.cpp:187:18: 
error: expected ';' before 'debMD5'
/build/buildd-qapt_1.3.0-1+b1-armel-vECdlq/qapt-1.3.0/src/debfile.cpp:191:5: 
error: 'debMD5' was not declared in this scope
make[3]: *** [src/CMakeFiles/qapt.dir/debfile.o] Error 1

Many (perhaps all, I haven't taken a detailed look at all the paralell build 
logs) other architectures are failing in the same way.




--- End Message ---
--- Begin Message ---
Source: apt
Source-Version: 0.9.3

We believe that the bug you reported is fixed in the latest version of
apt, which is due to be installed in the Debian FTP archive:

apt-doc_0.9.3_all.deb
  to main/a/apt/apt-doc_0.9.3_all.deb
apt-transport-https_0.9.3_amd64.deb
  to main/a/apt/apt-transport-https_0.9.3_amd64.deb
apt-utils_0.9.3_amd64.deb
  to main/a/apt/apt-utils_0.9.3_amd64.deb
apt_0.9.3.dsc
  to main/a/apt/apt_0.9.3.dsc
apt_0.9.3.tar.gz
  to main/a/apt/apt_0.9.3.tar.gz
apt_0.9.3_amd64.deb
  to main/a/apt/apt_0.9.3_amd64.deb
libapt-inst1.5_0.9.3_amd64.deb
  to main/a/apt/libapt-inst1.5_0.9.3_amd64.deb
libapt-pkg-dev_0.9.3_amd64.deb
  to main/a/apt/libapt-pkg-dev_0.9.3_amd64.deb
libapt-pkg-doc_0.9.3_all.deb
  to main/a/apt/libapt-pkg-doc_0.9.3_all.deb
libapt-pkg4.12_0.9.3_amd64.deb
  to main/a/apt/libapt-pkg4.12_0.9.3_amd64.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 669...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Michael Vogt <m...@debian.org> (supplier of updated apt package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Fri, 11 May 2012 17:16:22 +0200
Source: apt
Binary: apt libapt-pkg4.12 libapt-inst1.5 apt-doc libapt-pkg-dev libapt-pkg-doc 
apt-utils apt-transport-https
Architecture: source all amd64
Version: 0.9.3
Distribution: unstable
Urgency: low
Maintainer: APT Development Team <de...@lists.debian.org>
Changed-By: Michael Vogt <m...@debian.org>
Description: 
 apt        - commandline package manager
 apt-doc    - documentation for APT
 apt-transport-https - https download transport for APT
 apt-utils  - package managment related utility programs
 libapt-inst1.5 - deb package format runtime library
 libapt-pkg-dev - development files for APT's libapt-pkg and libapt-inst
 libapt-pkg-doc - documentation for APT development
 libapt-pkg4.12 - package managment runtime library
Closes: 554387 669163 669427 670979 671623 671721
Changes: 
 apt (0.9.3) unstable; urgency=low
 .
   [ David Kalnischkies ]
   * apt-pkg/contrib/strutl.cc:
     - remove the message size limit from ioprintf and strprintf
   * apt-pkg/contrib/configuration.cc:
     - add a more versatile Dump() method
     - normalize a bit by replacing // and /./ with / in FindFile
     - /dev/null is a special absolute path as it has no subdirectories
   * apt-pkg/acquire-worker.cc:
     - use Dump() to generate the configuration message for sending
   * cmdline/apt-config.cc:
     - make it possible to limit dump to a subtree
     - implement --empty and --format option for dump
   * apt-pkg/cdrom.cc:
     - use Dump() to generate the configuration output
   * apt-pkg/depcache.cc:
     - clearly separate 'positive' and 'negative' dependencies and
       their upgrade-resolution tries in MarkInstall and especially don't
       treat Conflicts differently compared to Breaks here
     - provider is only a possible solution if the provides has the right
       version (or none as we have no versioned provides in debian) and not
       if the version of the provider matches
   * edsp/edspsystem.cc:
     - check with RealFileExists for scenario file as otherwise a directory
       like one provided with RootDir triggers the usage of EDSP
   * debian/libapt-inst1.5.symbols:
     - use the correct library name the symbols header
   * apt-pkg/pkgcachegen.cc:
     - check if NewDescription allocation has failed and error out accordingly
     - check if we work on a valid description in IsDuplicateDescription as
       we end up working on dangling pointers otherwise which segfaults on
       s390x and ppc64 (Closes: #669427)
   * apt-pkg/deb/deblistparser.cc:
     - check length and containing chars for a given description md5sum
   * ensure that apti18n.h is included last as advertised (Closes: #671623)
   * apt-pkg/acquire-worker.cc:
     - revert the use of FileFd::Write in OutFdReady as we don't want error
       reports about EAGAIN here as we retry later. Thanks to YOSHINO Yoshihito
       for the report. (Closes: #671721)
   * apt-pkg/contrib/fileutl.cc:
     - check that the fd which are closed are valid
     - ensure that we do init d only once and especially not with its own
       content as this causes some "interesting" hickups resulting in segfaults
       as it seems (Closes: #554387, #670979)
     - collect zombie (de)compressor processes on reopen
     - ensure that in error conditions the Fail flag is set
     - ensure that d is set before accessing it
   * apt-pkg/aptconfiguration.cc:
     - use NULL instead of "" for no (un)compress parameters
   * apt-pkg/algorithms.cc:
     - factor out of ListUpdate a AcquireUpdate to be able to provide your
       own pkgAcquire fetcher to the wrapper
   * apt-inst/deb/debfile.h:
     - readd 'md5.h' to the uncleaned header includes to make qapt build
       against us again unchanged to unblock transition (Closes: #669163)
Checksums-Sha1: 
 f1c16f1b1161c6b628dccccfc70374bd39fc2301 1663 apt_0.9.3.dsc
 064de29b0c927de095e3b7b56c4acd966292c342 3421552 apt_0.9.3.tar.gz
 2f40c9c39036b4bbccbdca0079bd1f9f7d1eb14a 255586 apt-doc_0.9.3_all.deb
 e6fa24b0ee64a3aa83274ee20e534bf377089728 834062 libapt-pkg-doc_0.9.3_all.deb
 cec1976ee0f7a029eceaaf6ec6adcf3b50951aed 860984 libapt-pkg4.12_0.9.3_amd64.deb
 3219f9ce56ca88d5d053902ff6d53002b2a414df 158824 libapt-inst1.5_0.9.3_amd64.deb
 646eda5b6d51190181c15f5537428161f6f04c1d 1158196 apt_0.9.3_amd64.deb
 50ce89ac9e2c6916c41f414265874ea42e5af9e8 179066 libapt-pkg-dev_0.9.3_amd64.deb
 ca57e6a46f35ad22c9510344d1f61112ed1934fa 364230 apt-utils_0.9.3_amd64.deb
 5a4b3ae630879bced426e7b0822a2ef7bf3f4462 101314 
apt-transport-https_0.9.3_amd64.deb
Checksums-Sha256: 
 cae7eb967465accfc888ec8ab18800c9fb7f9855f31bc30b30bf7e9a8e826f2d 1663 
apt_0.9.3.dsc
 f0f79c7683abc886281d3b3f0b3fac705d5734a4456b9f61ae9211bfccb7a2dd 3421552 
apt_0.9.3.tar.gz
 daf4743cb2ae9caa4383fe02100b34fc1058a8ac7fec00898c74f86cc0abf7a9 255586 
apt-doc_0.9.3_all.deb
 5f3c9cf06bff4fe212724e5e4c6b7f2a180e149317fcf299b5dbfd33e19c167f 834062 
libapt-pkg-doc_0.9.3_all.deb
 1e39866e3e755241aa08d25e92da3470a69b25ad9b11401b1a7bf5a751288d69 860984 
libapt-pkg4.12_0.9.3_amd64.deb
 e9b3002e75abf28b0c506db303572f9cd1365aa8c3b506093f0ea980a257cf08 158824 
libapt-inst1.5_0.9.3_amd64.deb
 3183eff291d1e9d905e78a6b467bbfb90b20fc2808d50b5e91bf55158b4c18be 1158196 
apt_0.9.3_amd64.deb
 8f5b0906baa2fe875875d49f2e5acb47f6174ae6a2e65ef17a7ee5ad61bc4727 179066 
libapt-pkg-dev_0.9.3_amd64.deb
 ae288f9a564a5b4c656f91e2f551a59e47fddf1c877fcabaf5f3d86835ccedc8 364230 
apt-utils_0.9.3_amd64.deb
 83df94e2a279ab54498eb401a336006bd74bb438ede5593b305494b74b308cc6 101314 
apt-transport-https_0.9.3_amd64.deb
Files: 
 1161ee632e95b39c95ded93168836805 1663 admin important apt_0.9.3.dsc
 ecd3dae204aeb85cb4e8a327ba987aa4 3421552 admin important apt_0.9.3.tar.gz
 5338915df7b750d0903693bbb7ce0750 255586 doc optional apt-doc_0.9.3_all.deb
 35ac8e053998f73267b126a80366b8ef 834062 doc optional 
libapt-pkg-doc_0.9.3_all.deb
 3d00efdcbd8bcc6fbb252c5e7524197e 860984 admin important 
libapt-pkg4.12_0.9.3_amd64.deb
 5f6f5ccb7e7d01fa89fab288e786bf66 158824 admin important 
libapt-inst1.5_0.9.3_amd64.deb
 2519c8c1afd27e70cf4ac10a5fa46e32 1158196 admin important apt_0.9.3_amd64.deb
 e9dac0ab7c0868c9c2fcffcb36540310 179066 libdevel optional 
libapt-pkg-dev_0.9.3_amd64.deb
 dd49f467695aec0fab029e7c49f3ad22 364230 admin important 
apt-utils_0.9.3_amd64.deb
 88fc0a1204ed72391db9ecd8567f07e6 101314 admin optional 
apt-transport-https_0.9.3_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iEYEARECAAYFAk+tLn4ACgkQliSD4VZixzSILQCfXRk2ll0CsIZO+i/0m1092l31
1+IAmQGxmwH8RzcJiXi9Belo66JAoCcF
=XFyQ
-----END PGP SIGNATURE-----



--- End Message ---
_______________________________________________
pkg-kde-extras mailing list
pkg-kde-extras@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-kde-extras

Reply via email to