Package: amarok
Version: 2.5.0-1
Severity: important

Dear Maintainer,

today, after just starting Amarok after having switched to
Phonon VLC for testing whether Amarok does not skip or fail to
playback certain songs - I did logout and login to switch
- I just got:

Die Amarok-Datenbank berichtet die folgenden Fehler:
GREPME MySQLe query failed! (2000)  on init
In den meisten Fällen müssen diese Fehler behoben sein, bevor Amarok 
vollständig funktioniert.


Amarok then started, but collection is empty.

When I then quit Amarok its process is still there.

It doesn´t respond to a SIGINT.


martin@merkaba:~/.kde> date ; kill 30466
Fr 18. Mai 13:57:07 CEST 2012
martin@merkaba:~/.kde> date ; kill 30466
Fr 18. Mai 13:57:21 CEST 2012
martin@merkaba:~/.kde> date ; kill 30466
Fr 18. Mai 13:57:39 CEST 2012

martin@merkaba:~/.kde> ps aux | grep "/usr/bin/amarok" | grep -v grep
martin   30466  6.6  5.3 1205748 423804 ?      Sl   13:54   0:12 /usr/bin/amarok
martin@merkaba:~/.kde> date ; kill 30466                             
Fr 18. Mai 13:57:57 CEST 2012


strace had it at:

martin@merkaba:~> strace -fF -p 30466
Process 30466 attached with 9 threads - interrupt to quit
[pid 30486] futex(0x7fb6b4edbf54, FUTEX_WAIT_PRIVATE, 3, NULL <unfinished ...>
[pid 30484] select(5, [4], NULL, NULL, NULL <unfinished ...>
[pid 30482] futex(0x7fb6aee25354, FUTEX_WAIT_PRIVATE, 1, NULL <unfinished ...>
[pid 30481] futex(0xf44a1c, FUTEX_WAIT_PRIVATE, 101, NULL <unfinished ...>
[pid 30480] futex(0xf44a1c, FUTEX_WAIT_PRIVATE, 103, NULL <unfinished ...>
[pid 30481] <... futex resumed> )       = -1 EAGAIN (Resource temporarily 
unavailable)
[pid 30480] <... futex resumed> )       = -1 EAGAIN (Resource temporarily 
unavailable)
[pid 30481] futex(0xf44a1c, FUTEX_WAIT_PRIVATE, 104, NULL <unfinished ...>
[pid 30480] futex(0xf44a1c, FUTEX_WAIT_PRIVATE, 104, NULL <unfinished ...>
[pid 30479] futex(0xf44a1c, FUTEX_WAIT_PRIVATE, 104, NULL <unfinished ...>
[pid 30478] futex(0xf44a1c, FUTEX_WAIT_PRIVATE, 102, NULL) = -1 EAGAIN 
(Resource temporarily unavailable)
[pid 30477] restart_syscall(<... resuming interrupted call ...> <unfinished ...>
[pid 30478] futex(0xf44a1c, FUTEX_WAIT_PRIVATE, 104, NULL <unfinished ...>
[pid 30466] futex(0x7fb69a702480, FUTEX_WAIT_PRIVATE, 2, NULL^C <unfinished ...>
Process 30466 detached
Process 30477 detached
Process 30478 detached
Process 30479 detached
Process 30480 detached
Process 30481 detached
Process 30482 detached
Process 30484 detached
Process 30486 detached


Looking in ~/.kde/share/apps/amarok/mysqle database files appeared to
be fine.


I then used amarok --debug and got:

amarok:     BEGIN: MainWindow::MainWindow() 
amarok:       BEGIN: CollectionManager::CollectionManager() 
amarok:       END__: CollectionManager::CollectionManager() [Took: 0s] 
amarok:       BEGIN: Plugins::PluginManager::PluginManager(QObject*) 
amarok:         BEGIN: void Plugins::PluginManager::findAllPlugins() 
amarok:           [PluginManager] found plugin: 
"amarok_collection-audiocdcollection" enabled: true 
amarok:           [PluginManager] found plugin: 
"amarok_collection-daapcollection" enabled: true 
amarok:           [PluginManager] found plugin: 
"amarok_collection-mtpcollection" enabled: true 
amarok:           [PluginManager] found plugin: 
"amarok_collection-mysqlservercollection" enabled: true 
amarok:           [PluginManager] found plugin: 
"amarok_collection-mysqlecollection" enabled: true 
amarok:           [PluginManager] found plugin: 
"amarok_collection-upnpcollection" enabled: true 
amarok:           [PluginManager] found plugin: 
"amarok_collection-umscollection" enabled: true 
amarok:           [PluginManager] found plugin: 
"amarok_collection-ipodcollection" enabled: true 
amarok:           [PluginManager] found plugin: "amarok_device_massstorage" 
enabled: true 
amarok:           [PluginManager] found plugin: "amarok_device_nfs" enabled: 
true 
amarok:           [PluginManager] found plugin: "amarok_device_smb" enabled: 
true 
amarok:           [PluginManager] found plugin: "amarok_service_ampache" 
enabled: false 
amarok:           [PluginManager] found plugin: "amarok_service_jamendo" 
enabled: true 
amarok:           [PluginManager] found plugin: "amarok_service_lastfm" 
enabled: false 
amarok:           [PluginManager] found plugin: "amarok_service_amazonstore" 
enabled: true 
amarok:           [PluginManager] found plugin: "amarok_service_mp3tunes" 
enabled: false 
amarok:           [PluginManager] found plugin: "amarok_service_magnatunestore" 
enabled: true 
amarok:           [PluginManager] found plugin: "amarok_service_opmldirectory" 
enabled: true 
amarok:           [PluginManager] 18 plugins in total 
amarok:         END__: void Plugins::PluginManager::findAllPlugins() [Took: 
0.002s] 
amarok:         [PluginManager] created factory for plugin 
"amarok_collection-audiocdcollection" type: "Collection" 
amarok:         [PluginManager] created factory for plugin 
"amarok_collection-daapcollection" type: "Collection" 
amarok:         [PluginManager] created factory for plugin 
"amarok_collection-mtpcollection" type: "Collection" 
amarok:         [PluginManager] created factory for plugin 
"amarok_collection-mysqlecollection" type: "Collection" 
amarok:         [PluginManager] created factory for plugin 
"amarok_collection-upnpcollection" type: "Collection" 
amarok:         [PluginManager] created factory for plugin 
"amarok_collection-umscollection" type: "Collection" 
amarok:         [PluginManager] created factory for plugin 
"amarok_collection-ipodcollection" type: "Collection" 
amarok:         BEGIN: void CollectionManager::init(const 
QList<Plugins::PluginFactory*>&) 
amarok:           BEGIN: void CollectionManager::loadPlugins(const 
QList<Collections::CollectionFactory*>&) 
amarok:             [CollectionManager] initializing 
"amarok_collection-mysqlecollection" 


mysql_embedded: Can't read dir of '/etc/mysql/conf.d/' (Errcode: 2)
Fatal error in defaults handling. Program aborted


amarok:             [ERROR__] MySQL library initialization failed. 
amarok:             [ERROR__] [MySqlStorage] "GREPME MySQLe query failed! 
(2000)  on init" 


amarok:             BEGIN: bool DatabaseUpdater::update() 
amarok:               [MySqlStorage] Initialized thread, count== 1 
amarok:               [ERROR__] [MySqlStorage] Tried to perform query on 
uninitialized MySQL 
amarok:               Database version:  0 
amarok:               BEGIN: void DatabaseUpdater::createTables() const 
amarok:                 [ERROR__] [MySqlStorage] Tried to perform query on 
uninitialized MySQL 
[…]
amarok:                 [ERROR__] [MySqlStorage] Tried to perform query on 
uninitialized MySQL 
amarok:               END__: void DatabaseUpdater::createTables() const [Took: 
0s] 
amarok:               [ERROR__] [MySqlStorage] Tried to perform query on 
uninitialized MySQL 
amarok:             END__: bool DatabaseUpdater::update() [Took: 0s] 
amarok:             [ERROR__] [MySqlStorage] Tried to perform query on 
uninitialized MySQL 
[…]
amarok:             [ERROR__] [MySqlStorage] Tried to perform query on 
uninitialized MySQL 
amarok:             BEGIN: virtual int App::newInstance() 
amarok:               BEGIN: static void App::handleCliArgs() 
amarok:               END__: static void App::handleCliArgs() [Took: 0s] 
amarok:             END__: virtual int App::newInstance() [Took: 0s] 
martin@merkaba:~> amarok:             [ERROR__] [MySqlStorage] Tried to perform 
query on uninitialized MySQL 
amarok:             [ERROR__] [MySqlStorage] Tried to perform query on 
uninitialized MySQL 
[…]
amarok:             [ERROR__] [MySqlStorage] Tried to perform query on 
uninitialized MySQL 
amarok:             BEGIN: void ScanManager::checkScannerVersion() 
amarok:             END__: void ScanManager::checkScannerVersion() [Took: 
0.016s] 


Thus I did:

mkdir /etc/mysql/conf.d


Now Amarok starts up fine and collection is there.


merkaba:~> apt-show-versions | grep "mysql"  
libmysqlclient-dev/sid uptodate 5.5.23-2
libmysqlclient16/sid uptodate 5.1.62-1
libmysqlclient18/sid uptodate 5.5.23-2
libqt4-sql-mysql/sid uptodate 4:4.8.1-1
mysql-common/sid uptodate 5.5.23-2


I do think there are at least two possible upstream bugs involved here:

1) Amarok just still be SIGTERM-able on this situation.

2) Amarok should provide a better error message.


I also don´t know why it relies on system-wide configuration directory
when mysqle is used.

I won´t report anything upstream for now, cause I´d like to hear your
feedback first.

Thanks,
Martin


-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (120, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 3.3.0-trunk-amd64 (SMP w/4 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages amarok depends on:
ii  amarok-common                         2.5.0-1
ii  amarok-utils                          2.5.0-1
ii  kdebase-runtime                       4:4.8.3-0r1
ii  libavcodec53                          6:0.8.2-1
ii  libavformat53 [libavformat-extra-53]  6:0.8.2-1
ii  libc6                                 2.13-32
ii  libcurl3-gnutls                       7.25.0-1
ii  libgcc1                               1:4.7.0-8
ii  libgcrypt11                           1.5.0-3
ii  libgdk-pixbuf2.0-0                    2.26.1-1
ii  libgl1-mesa-glx [libgl1]              8.0.2-2
ii  libglib2.0-0                          2.32.3-1
ii  libgpod4-nogtk                        0.8.2-6
ii  libkcmutils4                          4:4.8.3-0r1
ii  libkdecore5                           4:4.8.3-0r1
ii  libkdeui5                             4:4.8.3-0r1
ii  libkdewebkit5                         4:4.8.3-0r1
ii  libkdnssd4                            4:4.8.3-0r1
ii  libkfile4                             4:4.8.3-0r1
ii  libkio5                               4:4.8.3-0r1
ii  libknewstuff3-4                       4:4.8.3-0r1
ii  liblastfm0                            0.4.0~git20090710-1
ii  libloudmouth1-0                       1.4.3-8
ii  libmtp9                               1.1.3-2
ii  libmysqlclient16                      5.1.62-1
ii  libofa0                               0.9.3-5
ii  libphonon4                            4:4.6.0.0-2
ii  libplasma3                            4:4.8.3-0r1
ii  libqjson0                             0.7.1-6
ii  libqt4-dbus                           4:4.8.1-1
ii  libqt4-network                        4:4.8.1-1
ii  libqt4-opengl                         4:4.8.1-1
ii  libqt4-script                         4:4.8.1-1
ii  libqt4-sql                            4:4.8.1-1
ii  libqt4-svg                            4:4.8.1-1
ii  libqt4-xml                            4:4.8.1-1
ii  libqtcore4                            4:4.8.1-1
ii  libqtgui4                             4:4.8.1-1
ii  libqtscript4-core                     0.2.0-1
ii  libqtscript4-gui                      0.2.0-1
ii  libqtscript4-network                  0.2.0-1
ii  libqtscript4-sql                      0.2.0-1
ii  libqtscript4-uitools                  0.2.0-1
ii  libqtscript4-xml                      0.2.0-1
ii  libqtwebkit4                          2.2.1-4+b1
ii  libsolid4                             4:4.8.3-0r1
ii  libstdc++6                            4.7.0-8
ii  libtag-extras1                        1.0.1-3
ii  libtag1c2a                            1.7.1-3
ii  libthreadweaver4                      4:4.8.3-0r1
ii  libx11-6                              2:1.4.99.901-2
ii  libxml2                               2.7.8.dfsg-9
ii  phonon                                4:4.6.0.0-2
ii  zlib1g                                1:1.2.7.dfsg-1

Versions of packages amarok recommends:
ii  kdemultimedia-kio-plugins  4:4.7.4-2

Versions of packages amarok suggests:
ii  libqt4-sql-mysql   4:4.8.1-1
ii  libqt4-sql-psql    4:4.8.1-1
ii  libqt4-sql-sqlite  4:4.8.1-1
ii  libxine1-ffmpeg    1.1.20.1-4
ii  moodbar            0.1.2-3

Versions of packages amarok-common depends on:
ii  perl  5.14.2-10

amarok-common recommends no packages.

Versions of packages amarok is related to:
ii  phonon-backend-gstreamer [phonon-backend]  4:4.6.0.0-2
ii  phonon-backend-vlc [phonon-backend]        0.5.0-1

-- no debconf information



_______________________________________________
pkg-kde-extras mailing list
pkg-kde-extras@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-kde-extras

Reply via email to