Source: kmymoney
Version: 4.6.2-3
Severity: normal
Tags: sid patch

Hi,

I recently uploaded libaqbanking 5.0.24-1 to the Debian archive, which bumps
the soname and changes some package names. For this reason all packages
build-depending on it need to adapt their build dependencies and need to be
rebuilt with libaqbanking34-dev installed.

The package kmymoney currently declares the build-dep as alternative:
'libaqbanking33-dev | libaqbanking-dev', so there seems to be no immediate need
for a source-full upload. Hence I am going to request a binNMU on kmymoney now
with the intention that the kmymoney binary packages pick up the new dependency
on libaqbanking34 in Debian unstable.

Nevertheless you should update kmymoney to build-depend on libaqbanking34-dev
instead of the disappeared libaqbanking33-dev in the next regular upload.

Regards,
Micha
Index: debian/control
===================================================================
--- debian/control	(Revision 19235)
+++ debian/control	(Arbeitskopie)
@@ -5,7 +5,7 @@
 Uploaders: Mark Purcell <m...@debian.org>, Fathi Boudra <f...@debian.org>
 Build-Depends: debhelper (>= 7.4.15), cmake, pkg-kde-tools (>= 0.9.0),
  kdelibs5-dev (>= 4:4.4.4), kdepimlibs5-dev (>= 4:4.4.4), shared-mime-info,
- libaqbanking33-dev | libaqbanking-dev, libgwenhywfar60-dev | libgwenhywfar-dev, 
+ libaqbanking34-dev | libaqbanking-dev, libgwenhywfar60-dev | libgwenhywfar-dev, 
  libboost-graph-dev, libfinance-quote-perl, libgpgme11-dev, libalkimia-dev,
  libical-dev, libjpeg-dev, libofx-dev, libgmp-dev,
  libpng-dev, libsqlite3-dev, zlib1g-dev, pkg-config
_______________________________________________
pkg-kde-extras mailing list
pkg-kde-extras@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-kde-extras

Reply via email to