Your message dated Mon, 25 Jun 2012 12:48:02 +0000
with message-id <e1sj8i2-00044z...@franck.debian.org>
and subject line Bug#634787: fixed in kwave 0.8.8-1-3
has caused the Debian Bug report #634787,
regarding kwave: debian/control uses hardcoded list of non-Linux architectures
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
634787: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=634787
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: kwave
Severity: wishlist
User: debian-de...@lists.debian.org
Usertags: linux-any

The debian/control file in kwave uses a negated list of architectures
to specify a package relationship (most likely Build-Depends) on a
Linux-specific package.  I.e. something like:

 Build-Depends: libfoo-dev [!kfreebsd-i386 !kfreebsd-amd64 !hurd-i386]

This is problematic because it will fail for any future kfreebsd-* or hurd-*
architecture (like the upcoming kfreebsd-mipsel port).  The correct way
would be to use dpkg architecture wildcards, e.g.:

 Build-Depends: libfoo-dev [linux-any]

Please consider making this adjustment to make life easier for future
porting efforts.

Thanks!



--- End Message ---
--- Begin Message ---
Source: kwave
Source-Version: 0.8.8-1-3

We believe that the bug you reported is fixed in the latest version of
kwave, which is due to be installed in the Debian FTP archive:

kwave-dbg_0.8.8-1-3_amd64.deb
  to main/k/kwave/kwave-dbg_0.8.8-1-3_amd64.deb
kwave_0.8.8-1-3.debian.tar.gz
  to main/k/kwave/kwave_0.8.8-1-3.debian.tar.gz
kwave_0.8.8-1-3.dsc
  to main/k/kwave/kwave_0.8.8-1-3.dsc
kwave_0.8.8-1-3_amd64.deb
  to main/k/kwave/kwave_0.8.8-1-3_amd64.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 634...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Mark Purcell <m...@debian.org> (supplier of updated kwave package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Mon, 25 Jun 2012 20:04:35 +1000
Source: kwave
Binary: kwave kwave-dbg
Architecture: source amd64
Version: 0.8.8-1-3
Distribution: unstable
Urgency: low
Maintainer: Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org>
Changed-By: Mark Purcell <m...@debian.org>
Description: 
 kwave      - sound editor for KDE
 kwave-dbg  - sound editor for KDE - debug symbols
Closes: 634787
Changes: 
 kwave (0.8.8-1-3) unstable; urgency=low
 .
   * wheezy polish
   * Fix "debian/control uses hardcoded list of non-Linux architectures"
    (Closes: #634787)
   * Update Standards-Version 3.9.3
   * debian/compat -> 9
Checksums-Sha1: 
 083da7f3ba96c2f33e38ecaa9cf3991a87720869 1670 kwave_0.8.8-1-3.dsc
 c98ab79a8e6e6f10f1f6efdf6bcb5a8ad7784e00 15385 kwave_0.8.8-1-3.debian.tar.gz
 c1cbf5a0562a918cf24b4fe774641c4d6243ddd6 4308362 kwave_0.8.8-1-3_amd64.deb
 a69e28f43f7b91ffc570bf876d99feba1c9b30e5 5275936 kwave-dbg_0.8.8-1-3_amd64.deb
Checksums-Sha256: 
 2af937ff4b1f4f964836d3f2d6aba88f932a3fc03172f57ae8fc5b3233fb7728 1670 
kwave_0.8.8-1-3.dsc
 c6e48885d5697371db964817ad9e03fa9f62478ae8e2cdbddf9dd5504e1abf6a 15385 
kwave_0.8.8-1-3.debian.tar.gz
 13d81e7c48eb18790412efe43084dcc519a174407b49e0f3cd1570545daacf98 4308362 
kwave_0.8.8-1-3_amd64.deb
 08fb9c54798b991f1398f7fa9bc4e0925138fed7c63167bcd87b6288c4f82222 5275936 
kwave-dbg_0.8.8-1-3_amd64.deb
Files: 
 17e48e1afb27aa88e98dfd3edfce3e35 1670 kde optional kwave_0.8.8-1-3.dsc
 4e2482e8500a4a82599d6012502fc687 15385 kde optional 
kwave_0.8.8-1-3.debian.tar.gz
 03d88e19136d6fb3715be36501d0afaf 4308362 kde optional kwave_0.8.8-1-3_amd64.deb
 8ff61e701d7661ddbf720f8642b35944 5275936 debug extra 
kwave-dbg_0.8.8-1-3_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iEYEARECAAYFAk/oWXYACgkQoCzanz0IthL5DACdHBRb0VySOGrlO3rwZb3iYf0O
xZ4An0DKxu9xopNIJxalbxsQBcZdDErv
=TeYD
-----END PGP SIGNATURE-----



--- End Message ---
_______________________________________________
pkg-kde-extras mailing list
pkg-kde-extras@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-kde-extras

Reply via email to