merge 689047 689004
retitle 689004 digikam/3.0 conficts with kdegraphics/4.8
found 689047 4:3.0.0~beta1a-1
notfound 689047 3.0.0~beta1a-1
thanks

On Sat, 29 Sep 2012 02:53:51 Eric Valette wrote:
> Package: digikam
> Version: 3.0.0~beta1a-1
> Severity: grave
> Justification: renders package unusable
> 
> See the changelog and bug  689004.
> 

Eric,

I seem to be unable to email you directly, all email returns with a 550 error, 
so I will continue to utilise the BTS.

digikam/experimental is installable now (see below), but it does conflict with 
kdegraphics/unstable.  It installs fine and is a fully usable package (contary 
to your assertions), and some users wish to utilise the latest upstream 
release, which is why I have uploaded to experimental.

However, you are correct that this is not an acceptable long terms solution 
and is a release critical bug and should not be brought into unstable, hence 
why it is uploaded to experimental.  Upstream has a peculiar approach where 
they start utilising newer components of kdegraphics.  Again you are correct 
this is not the debian way and is not a sensible approach to packaging.  We 
also had exactly the same issue with the release of digikam/2.0 which was 
using unreleased features from kdegraphics/4.7.  The workaround we used then, 
and are using now is to make the bleeding edge package available via 
experimenal, whilst maintaining the fully compatible package via unstable.

So debian users have a number of choices:

1.      Bleeding edge digikam/3.0.  In which case they can install via 
experimental but cannot utilise kdegraphics/4.8.

2.      Integrated digikam/2.6 kdegraphics/4.8. In which case they can install 
from unstable/ testing and shortly stable..  Once stable is released I will 
likley release digikam/2.9 to unstable/testing.

3.      Roll their own.


I think this is a perfectly reasonable approach, which I understand you are 
not happy with.  However I would refer you to the headline for experimental 
packages:

http://packages.debian.org/experimental/digikam

        Package: digikam (4:3.0.0~beta1a-1)

        Warning: This package is from the experimental distribution. That means
        it is likely unstable or buggy, and it may even cause data loss. Please
        be sure to consult the changelog and other possible documentation before
        using it.

Mark




# apt-get -t experimental install digikam
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  digikam-data kipi-plugins kipi-plugins-common
Suggested packages:
  gallery gimp
The following packages will be REMOVED:
  gwenview kdegraphics kdegraphics-thumbnailers ksnapshot libkdcraw-data 
libkdcraw20 libkexiv2-10 libkexiv2-data libkipi-data libkipi8
The following NEW packages will be installed:
  digikam digikam-data kipi-plugins kipi-plugins-common
0 upgraded, 4 newly installed, 10 to remove and 398 not upgraded.
Need to get 0 B/36.5 MB of archives.
After this operation, 89.4 MB of additional disk space will be used.
Do you want to continue [Y/n]? 
Retrieving bug reports... Done
Parsing Found/Fixed information... Done
grave bugs of digikam (-> 4:3.0.0~beta1a-1) <unfixed>
 #689047 - digikam: Maintainer deliberately uploaded a package in experimental 
that will not be installable for months
 #689004 - digikam again not installable
Summary:
 digikam(2 bugs)
Are you sure you want to install/upgrade the above packages? [Y/n/?/...] 
(Reading database ... 329290 files and directories currently installed.)
Removing kdegraphics ...
Removing gwenview ...
Removing kdegraphics-thumbnailers ...
Removing ksnapshot ...
Removing libkdcraw20 ...
Removing libkdcraw-data ...
Removing libkexiv2-10 ...
Removing libkexiv2-data ...
Removing libkipi8 ...
Removing libkipi-data ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Selecting previously unselected package kipi-plugins-common.
(Reading database ... 329159 files and directories currently installed.)
Unpacking kipi-plugins-common (from .../kipi-plugins-
common_4%3a3.0.0~beta1a-1_all.deb) ...
Selecting previously unselected package kipi-plugins.
Unpacking kipi-plugins (from .../kipi-plugins_4%3a3.0.0~beta1a-1_amd64.deb) 
...
Selecting previously unselected package digikam-data.
Unpacking digikam-data (from .../digikam-data_4%3a3.0.0~beta1a-1_all.deb) ...
Selecting previously unselected package digikam.
Unpacking digikam (from .../digikam_4%3a3.0.0~beta1a-1_amd64.deb) ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for menu ...
Processing triggers for man-db ...
Setting up kipi-plugins-common (4:3.0.0~beta1a-1) ...
Setting up digikam-data (4:3.0.0~beta1a-1) ...
Setting up digikam (4:3.0.0~beta1a-1) ...
Setting up kipi-plugins (4:3.0.0~beta1a-1) ...
Processing triggers for menu ...

Attachment: signature.asc
Description: This is a digitally signed message part.

_______________________________________________
pkg-kde-extras mailing list
pkg-kde-extras@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-kde-extras

Reply via email to