Hi again,

> after choosing the oxygen style for GTK2 applications, emacs no longer starts.
> The process hangs before opening the window.
> 
> While debugging the issue, I read somewhere that GTK styles using C++ 
> sometimes
> cause mysterious issues caused e.g. by mismatching libstdc++ versions within
> the same application. QtCurve shows the same symptoms, so this may well be 
> that
> the cause of the problem. Furthermore, this started happening about the same
> time as I updated libc to 2.17 from unstable (I have a testing system
> otherwise). I recompiled the package on my system, but that did not change
> anything.
Some followup information:
I ran emacs in gdb and caught a backtrace of the deadlock. Here it is:

#0  0x00007ffff230519d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007ffff59efdac in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ffff59f028a in g_main_loop_run () from
/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ffff5a31ae1 in g_spawn_sync () from
/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007ffff5a31f58 in g_spawn_command_line_sync () from
/lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fffed548ce4 in Oxygen::QtSettings::kdeConfigPathList() const
() from /usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/engines/liboxygen-gtk.so
#6  0x00007fffed54f1ad in Oxygen::QtSettings::initialize(unsigned int)
() from /usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/engines/liboxygen-gtk.so
#7  0x00007fffed560d56 in Oxygen::Style::initialize(unsigned int) ()
from /usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/engines/liboxygen-gtk.so
#8  0x00007fffed562215 in Oxygen::Style::instance() () from
/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/engines/liboxygen-gtk.so
#9  0x00007fffed5a6d36 in theme_init () from
/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/engines/liboxygen-gtk.so
#10 0x00007ffff799cd76 in ?? () from
/usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0

It goes on a bit, but the offending line on the style is obviously

if( g_spawn_command_line_sync( "kde4-config --path config", &path, 0L,
0L, 0L ) && path )

in oxygengtksettings.cpp. I also checked my dpkg logs, and indeed I
updated libglib yesterday morning, and it was yesterday afternoon that I
first noticed this problem. So it's probably some behavioural change in
libglib which broke this. Should the bug be re-assigned?

Kind regards
Ralf

_______________________________________________
pkg-kde-extras mailing list
pkg-kde-extras@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-kde-extras

Reply via email to