Package: skanlite
Version: 0.8-2
Severity: important

Dear Maintainer,
After a brief period in which it worked, skanlite is no longer able to access
my
scanner.  Since this makes it completely unusable for me, I have raised the
severity.

   * What led up to the situation?
Installed skanlite.
Started it; could not find scanner.
Plugged in scanner (duh).
Rescan still didn't find scanner.
Relaunching application -> found scanner.
Edited some scanning options (1 bit B/W scans), previewed, scanned and saved
image.
Expanded and shrunk various windows and redid preview scan.
Reduced to 400 dpi.
Tried to select an area to scan.  The entire area was highlighted, but several
smaller squares with red borders were also apparent.  I might have accidentally
clicked to create them.
Requested scan; the areas with red borders were scanned successively, with me
hitting cancel after each one.
I also hit the red button on the bottom right of the window that showed between
scans.
In the main window, right click to deselect all the little squares.
Highlight the overall area to scan.
Request scan.  It may be relevant that significant time (1-2 minutes?) had
passed since my last scan or preview.
After a slight delay skanlite reported (roughly) I/O error: unable to contact
device.  Note that the application was
open continuously between the time it worked and the time it failed. About this
time kern.log shows the last message below:
<kern.log>
Aug 24 11:31:37 tempserver kernel: [6950072.448058] usb 3-1.2: new high-speed
USB device number 9 using ehci_hcd
Aug 24 11:31:37 tempserver kernel: [6950072.547022] usb 3-1.2: New USB device
found, idVendor=04b8, idProduct=011e
Aug 24 11:31:37 tempserver kernel: [6950072.547027] usb 3-1.2: New USB device
strings: Mfr=1, Product=2, SerialNumber=0
Aug 24 11:31:37 tempserver kernel: [6950072.547030] usb 3-1.2: Product: EPSON
Scanner
Aug 24 11:31:37 tempserver kernel: [6950072.547033] usb 3-1.2: Manufacturer:
EPSON
Aug 24 11:46:03 tempserver kernel: [6950936.545558] usb 3-1.2: usbfs: interface
0 claimed by usbfs while 'skanlite' sets config #1
</kern.log>
Tried again, no luck.
Relaunched application -> "Sorry, No devices found" after a pause.
Repeated relaunches and rescans did not help.

   * What exactly did you do (or not do) that was effective (or
     ineffective)?
See above.
Also searched for similar bugs.  The closest, because it involved usbfs, is
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=546558 (fixed in 2009, and
says claimed by usb-storage, while I have usbfs).

There are a number of similar reports, but they seem to involve cups and usblp.
I'm running cups, but usblp does not seem to be the
problem.
http://worldforum.pardus-linux.nl/index.php?topic=4133.0
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=546558

   * What was the outcome of this action?
No resolution found.  Unable to scan.

   * What outcome did you expect instead?
Able to scan.



-- System Information:
Debian Release: 7.1
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.2.0-4-amd64 (SMP w/8 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages skanlite depends on:
ii  kde-runtime  4:4.8.4-2
ii  libc6        2.13-38
ii  libkdecore5  4:4.8.4-4
ii  libkdeui5    4:4.8.4-4
ii  libkio5      4:4.8.4-4
ii  libksane0    4:4.8.4-1
ii  libpng12-0   1.2.49-1
ii  libqtcore4   4:4.8.2+dfsg-11
ii  libqtgui4    4:4.8.2+dfsg-11
ii  libstdc++6   4.7.2-5

skanlite recommends no packages.

Versions of packages skanlite suggests:
pn  skanlite-dbg  <none>

-- no debconf information

_______________________________________________
pkg-kde-extras mailing list
pkg-kde-extras@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-kde-extras

Reply via email to