Your message dated Sat, 09 Nov 2013 10:14:02 +1100
with message-id <9440641.9YDmqLSYua@acer>
and subject line Re: Bug#669387: digikam: upgrades database from v5 to v6 first 
time, then tries again and fails on next launch
has caused the Debian Bug report #669387,
regarding digikam: upgrades database from v5 to v6 first time, then tries again 
and fails on next launch
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact

Debian Bug Tracking System
Contact with problems
--- Begin Message ---
Package: digikam
Version: 4:2.6.0~beta3-1
Severity: normal

Dear Maintainer,
*** Please consider answering these questions, where appropriate ***

   * What led up to the situation?
   * What exactly did you do (or not do) that was effective (or
   * What was the outcome of this action?
   * What outcome did you expect instead?

*** End of the template - remove these lines ***

I just got this version of digikam from unstable update, and upon
launch, it said it was updating the database (which is the default
sqlite in my case) from v5 to v6.  Upon finishing the upgrade,
digikam showed me all my images, and seemed fine.

I shutdown digikam and then started it again a day later, and it
said again it was "Scanning collection" and quickly popped an error
that it failed to upgrade database from v5 to v6. Upon continuing,
no images were shown in digikam.

I restored my digikam sqlite files from backups, and reproduced the
behavior -- upgrade worked, then upgrade tried to apply again on
next start and failed.

To work around the issue, I opened the digikam4.db -> Settings
table, and found DBVersion still set to 5.  I bumped it up to 6,
and digikam started OK for me, showed me my images, and I'm
importing images again -- it seems OK now.

-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.3.2 (SMP w/2 CPU cores; PREEMPT)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages digikam depends on:
ii  digikam-data            4:2.6.0~beta3-1
ii  kde-runtime             4:4.7.4-2
ii  libc6                   2.13-30
ii  libgcc1                 1:4.7.0-3
ii  libgomp1                4.7.0-3
ii  libgphoto2-2            2.4.14-1
ii  libgphoto2-port0        2.4.14-1
ii  libjasper1              1.900.1-13
ii  libjpeg8                8d-1
ii  libkdcraw20             4:4.7.4-2
ii  libkdecore5             4:4.7.4-4
ii  libkdeui5               4:4.7.4-4
ii  libkdewebkit5           4:4.7.4-4
ii  libkexiv2-10            4:4.7.4-2
ii  libkfile4               4:4.7.4-4
ii  libkhtml5               4:4.7.4-4
ii  libkio5                 4:4.7.4-4
ii  libkipi8                4:4.7.4-2
ii  libknotifyconfig4       4:4.7.4-4
ii  libkparts4              4:4.7.4-4
ii  liblcms1                1.19.dfsg-1+b1
ii  liblensfun0             0.2.5-2
ii  liblqr-1-0              0.4.1-1.1
ii  libmarblewidget12       4:4.7.4-2
ii  libnepomuk4             4:4.7.4-4
ii  libopencv-core2.3       2.3.1-8
ii  libopencv-highgui2.3    2.3.1-8
ii  libopencv-imgproc2.3    2.3.1-8
ii  libopencv-legacy2.3     2.3.1-8
ii  libopencv-objdetect2.3  2.3.1-8
ii  libphonon4              4:
ii  libpng12-0              1.2.49-1
ii  libqjson0               0.7.1-6
ii  libqt4-dbus             4:4.7.4-3
ii  libqt4-network          4:4.7.4-3
ii  libqt4-qt3support       4:4.7.4-3
ii  libqt4-sql              4:4.7.4-3
ii  libqt4-sql-sqlite       4:4.7.4-3
ii  libqt4-xml              4:4.7.4-3
ii  libqtcore4              4:4.7.4-3
ii  libqtgui4               4:4.7.4-3
ii  libqtwebkit4            2.2.0-5
ii  libsolid4               4:4.7.4-4
ii  libsoprano4             2.7.5+dfsg.1-1
ii  libstdc++6              4.7.0-3
ii  libtiff4                3.9.6-3
ii  libx11-6                2:1.4.4-4
ii  phonon                  4:

Versions of packages digikam recommends:
ii  chromium [www-browser]          18.0.1025.151~r130497-1
ii  epiphany-browser [www-browser]  3.2.1-2
ii  iceweasel [www-browser]         10.0.3esr-3
ii  kipi-plugins                    4:2.6.0~beta3-1
ii  konqueror [www-browser]         4:4.7.4-2
ii  lynx-cur [www-browser]          2.8.8dev.12-2
ii  mplayerthumbs                   4:4.7.4-2

Versions of packages digikam suggests:
ii  digikam-doc  4:2.6.0~beta3-1

-- no debconf information

--- End Message ---
--- Begin Message ---
On Thu, 19 Apr 2012 10:01:54 John Flinchbaugh wrote:
> Version: 4:2.6.0~beta3-1


I have closed this report as it is against a very old version of digikam which 
is no longer supported by Debian.

I am sorry we have not been able to resolve this issue for you.

Upstream also provide support for digikam here:

If this is an ongoing issue, could I ask you to file a new report against a 
newer version of digikam which is supported by Debian.


Attachment: signature.asc
Description: This is a digitally signed message part.

--- End Message ---
pkg-kde-extras mailing list

Reply via email to