Your message dated Sat, 7 Dec 2013 15:24:24 +0100
with message-id <20131207142424.ga25...@olivierberger.com>
and subject line Re: Bug#731601: digikam: Opening read-only digikam3.db reports 
shema update problem
has caused the Debian Bug report #731601,
regarding digikam: Opening read-only digikam3.db reports shema update problem
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
731601: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=731601
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: digikam
Version: 4:3.4.0-1
Severity: normal

Hi.

I'm managing my photos with git-annex, which happens to protect files from 
modification, by creating, instead of files, a symlink pointing to a read-only 
file somewhere down a .git/annex subdir.

So, for instance, I have :
$ ls -l digikam4.db
lrwxrwxrwx 1 olivier olivier 198 déc.   7 14:59 digikam4.db -> 
.git/annex/objects/mk/q9/SHA256E-s22285312--00966fe43a70441d7cca4797ca18bf2d9d9d9f87ee7d5c599b230871ecbf25c7.db/SHA256E-s22285312--00966fe43a70441d7cca4797ca18bf2d9d9d9f87ee7d5c599b230871ecbf25c7.db
$ ls -l 
.git/annex/objects/mk/q9/SHA256E-s22285312--00966fe43a70441d7cca4797ca18bf2d9d9d9f87ee7d5c599b230871ecbf25c7.db/SHA256E-s22285312--00966fe43a70441d7cca4797ca18bf2d9d9d9f87ee7d5c599b230871ecbf25c7.db
-r--r--r-- 1 olivier olivier 22285312 mai   28  2013 
.git/annex/objects/mk/q9/SHA256E-s22285312--00966fe43a70441d7cca4797ca18bf2d9d9d9f87ee7d5c599b230871ecbf25c7.db/SHA256E-s22285312--00966fe43a70441d7cca4797ca18bf2d9d9d9f87ee7d5c599b230871ecbf25c7.db

In such a situation, digikam doesn't complain that the file is read-only or a 
symlink, but reports a DB schema update problem.

Logs have :
$ LANG=C digikam 
digikam(24885)/digikam (core) Digikam::KInotify::Private::open: Successfully 
opened connection to inotify: 21
digikam(24885)/digikam (core) Digikam::AlbumWatch::connectToKDirWatch: 
KDirWatch method =  "INotify"
Object::connect: No such signal 
org::freedesktop::UPower::DeviceAdded(QDBusObjectPath)
Object::connect: No such signal 
org::freedesktop::UPower::DeviceRemoved(QDBusObjectPath)
digikam(24885)/digikam (core) Digikam::AlbumManager::setDatabase: 
DatabaseParameters: [ Type "QSQLITE", Name "/home/olivier/photos/digikam4.db" 
(Thumbnails Name "/home/olivier/photos/thumbnails-digikam.db"); ]
QSqlDatabasePrivate::removeDatabase: connection 'ConnectionTest' is still in 
use, all queries will cease to work.
digikam(24885)/digikam (core) Digikam::DatabaseConfigElementLoader::readConfig: 
Loading SQL code from config file 
"/usr/share/kde4/apps/digikam/database/dbconfig.xml"
digikam(24885)/digikam (core) Digikam::DatabaseConfigElementLoader::readConfig: 
false "1" 1 1
digikam(24885)/digikam (core) Digikam::SchemaUpdater::update: SchemaUpdater 
update
digikam(24885)/digikam (core) Digikam::SchemaUpdater::startUpdates: Have a 
database structure version  6
digikam(24885)/digikam (core) Digikam::SchemaUpdater::makeUpdates: makeUpdates  
6  to  7
digikam(24885)/digikam (core) 
Digikam::DatabaseCoreBackendPrivate::debugOutputFailedQuery: Failure executing 
query:
 "" 
Error messages: "Unable to fetch row" "attempt to write a readonly database" 8 
1 
Bound values:  ()
digikam(24885)/digikam (core) Digikam::DatabaseCoreBackend::execDBAction: Error 
while executing DBAction [ "UpdateSchemaFromV6ToV7" ] Statement [ " CREATE 
TABLE VideoMetadata
                            (imageid INTEGER PRIMARY KEY,
                            aspectRatio TEXT,
                            audioBitRate TEXT,
                            audioChannelType TEXT,
                            audioCompressor TEXT,
                            duration TEXT,
                            frameRate TEXT,
                            exposureProgram INTEGER,
                            videoCodec TEXT)" ]
digikam(24885)/digikam (core): Schema update to V 7 failed! 

I guess there is indeed an error reported by the underlying DB access manager, 
but which seems to be interpreted wrongly as a schema mismatch.

This is quite misleading and may be improved with a proper file writeability 
test, IMHO.

Hope this helps.

Best regards,
-- System Information:
Debian Release: jessie/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.11-2-amd64 (SMP w/2 CPU cores)
Locale: LANG=fr_FR.utf8, LC_CTYPE=fr_FR.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages digikam depends on:
ii  digikam-data          4:3.4.0-1
ii  digikam-private-libs  4:3.4.0-1
ii  kde-runtime           4:4.11.3-1
ii  libc6                 2.17-93
ii  libgcc1               1:4.8.2-1
ii  libgphoto2-2          2.4.14-2.4
ii  libgphoto2-port0      2.4.14-2.4
ii  libkdcraw22           4:4.11.3-1
ii  libkdecore5           4:4.11.3-2
ii  libkdeui5             4:4.11.3-2
ii  libkexiv2-11          4:4.11.3-1
ii  libkhtml5             4:4.11.3-2
ii  libkio5               4:4.11.3-2
ii  libkipi10             4:4.10.5-1
ii  libknotifyconfig4     4:4.11.3-2
ii  libkparts4            4:4.11.3-2
ii  libphonon4            4:4.7.0.0-2
ii  libqt4-dbus           4:4.8.5+git121-g2a9ea11+dfsg1-2
ii  libqt4-sql            4:4.8.5+git121-g2a9ea11+dfsg1-2
ii  libqt4-sql-sqlite     4:4.8.5+git121-g2a9ea11+dfsg1-2
ii  libqt4-xml            4:4.8.5+git121-g2a9ea11+dfsg1-2
ii  libqtcore4            4:4.8.5+git121-g2a9ea11+dfsg1-2
ii  libqtgui4             4:4.8.5+git121-g2a9ea11+dfsg1-2
ii  libsolid4             4:4.11.3-2
ii  libstdc++6            4.8.2-1
ii  libthreadweaver4      4:4.11.3-2
ii  perl                  5.18.1-4
ii  phonon                4:4.7.0.0-2

Versions of packages digikam recommends:
ii  chromium [www-browser]          31.0.1650.57-1
ii  epiphany-browser [www-browser]  3.8.2-4
ii  iceweasel [www-browser]         17.0.9esr-1~deb7u1
ii  kipi-plugins                    4:3.4.0-1
ii  konqueror [www-browser]         4:4.11.3-1
ii  mplayerthumbs                   4:4.11.3-1
ii  w3m [www-browser]               0.5.3-12

Versions of packages digikam suggests:
pn  digikam-doc     <none>
pn  systemsettings  <none>

-- no debconf information

--- End Message ---
--- Begin Message ---
On Sat, Dec 07, 2013 at 03:09:03PM +0100, Olivier Berger wrote:
> 
... alot of CARP, SNIP

Sorry about the bothering.

My usage of git-annex is problematic, and I kind of understand that I've 
reverted my file to an earlier version, trying to demonstrate the occurrence of 
the bug, while investigatin on #718439.

Hence closing.

Sorry again.

Best regards,
-- 
Olivier BERGER 
(OpenPGP: 4096R/7C5BB6A5 : http://weusepgp.info)
http://www.olivierberger.com/weblog/

--- End Message ---
_______________________________________________
pkg-kde-extras mailing list
pkg-kde-extras@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-kde-extras

Reply via email to