Your message dated Tue, 12 Aug 2014 15:36:56 +0000
with message-id <e1xhe88-00057n...@franck.debian.org>
and subject line Bug#746894: fixed in qapt 1.3.0-2.1
has caused the Debian Bug report #746894,
regarding qapt: ftbfs with GCC-4.9
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
746894: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=746894
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: src:qapt
Version: 1.3.0-2
Severity: important
Tags: sid jessie
User: debian-...@lists.debian.org
Usertags: ftbfs-gcc-4.9

The package fails to build in a test rebuild on at least amd64 with
gcc-4.9/g++-4.9, but succeeds to build with gcc-4.8/g++-4.8. The
severity of this report may be raised before the jessie release.

The full build log can be found at:
http://people.debian.org/~doko/logs/failed-gcc49/qapt_1.3.0-2_unstable_gcc49.log
The last lines of the build log are at the end of this report.

To build with GCC 4.9, either set CC=gcc-4.9 CXX=g++-4.9 explicitly,
or install the gcc, g++, gfortran, ... packages from experimental.

  apt-get -t experimental install g++ 

Common build failures are new warnings resulting in build failures
with -Werror turned on, or new/dropped symbols in Debian symbols
files.  For other C/C++ related build failures see the porting guide
at http://gcc.gnu.org/gcc-4.9/porting_to.html

[...]
+#MISSING: 1.3.0-2# _ZNSt6vectorISsSaISsEED2Ev@Base 1.2.2
+#MISSING: 1.3.0-2# 
(optional=templinst)_ZSt6__findIN9__gnu_cxx17__normal_iteratorIPP12pkgIndexFileSt6vectorIS3_SaIS3_EEEES3_ET_S9_S9_RKT0_St26random_access_iterator_tag@Base
 1.1.0
  _ZTIN4QApt5CacheE@Base 0.3.0
  _ZTIN4QApt6ConfigE@Base 1.0.60
  _ZTIN4QApt7BackendE@Base 0.3.0
@@ -289,13 +291,13 @@
  _ZTIN6Xapian13DatabaseErrorE@Base 0.3.0
  _ZTIN6Xapian20DatabaseOpeningErrorE@Base 0.3.0
  _ZTIN6Xapian5ErrorE@Base 0.3.0
- 
(regex|optional=templinst)_ZTISt8iteratorISt20forward_iterator_tagN8pkgCache10DependencyE[il]PS2_RS2_E@Base
 1.1.0
- 
(regex|optional=templinst)_ZTISt8iteratorISt20forward_iterator_tagN8pkgCache11PackageFileE[il]PS2_RS2_E@Base
 1.1.0
- 
(regex|optional=templinst)_ZTISt8iteratorISt20forward_iterator_tagN8pkgCache7PackageE[il]PS2_RS2_E@Base
 1.1.0
- 
(regex|optional=templinst)_ZTISt8iteratorISt20forward_iterator_tagN8pkgCache7VerFileE[il]PS2_RS2_E@Base
 1.1.0
- 
(regex|optional=templinst)_ZTISt8iteratorISt20forward_iterator_tagN8pkgCache7VersionE[il]PS2_RS2_E@Base
 1.1.0
- 
(regex|optional=templinst)_ZTISt8iteratorISt20forward_iterator_tagN8pkgCache8DescFileE[il]PS2_RS2_E@Base
 1.1.0
- 
(regex|optional=templinst)_ZTISt8iteratorISt20forward_iterator_tagN8pkgCache8ProvidesE[il]PS2_RS2_E@Base
 1.1.0
+#MISSING: 1.3.0-2# 
(regex|optional=templinst)_ZTISt8iteratorISt20forward_iterator_tagN8pkgCache10DependencyE[il]PS2_RS2_E@Base
 1.1.0
+#MISSING: 1.3.0-2# 
(regex|optional=templinst)_ZTISt8iteratorISt20forward_iterator_tagN8pkgCache11PackageFileE[il]PS2_RS2_E@Base
 1.1.0
+#MISSING: 1.3.0-2# 
(regex|optional=templinst)_ZTISt8iteratorISt20forward_iterator_tagN8pkgCache7PackageE[il]PS2_RS2_E@Base
 1.1.0
+#MISSING: 1.3.0-2# 
(regex|optional=templinst)_ZTISt8iteratorISt20forward_iterator_tagN8pkgCache7VerFileE[il]PS2_RS2_E@Base
 1.1.0
+#MISSING: 1.3.0-2# 
(regex|optional=templinst)_ZTISt8iteratorISt20forward_iterator_tagN8pkgCache7VersionE[il]PS2_RS2_E@Base
 1.1.0
+#MISSING: 1.3.0-2# 
(regex|optional=templinst)_ZTISt8iteratorISt20forward_iterator_tagN8pkgCache8DescFileE[il]PS2_RS2_E@Base
 1.1.0
+#MISSING: 1.3.0-2# 
(regex|optional=templinst)_ZTISt8iteratorISt20forward_iterator_tagN8pkgCache8ProvidesE[il]PS2_RS2_E@Base
 1.1.0
  _ZTSN4QApt5CacheE@Base 0.3.0
  _ZTSN4QApt6ConfigE@Base 1.0.60
  _ZTSN4QApt7BackendE@Base 0.3.0
@@ -305,13 +307,13 @@
  _ZTSN6Xapian13DatabaseErrorE@Base 0.3.0
  _ZTSN6Xapian20DatabaseOpeningErrorE@Base 0.3.0
  _ZTSN6Xapian5ErrorE@Base 0.3.0
- 
(regex|optional=templinst)_ZTSSt8iteratorISt20forward_iterator_tagN8pkgCache10DependencyE[il]PS2_RS2_E@Base
 1.1.0
- 
(regex|optional=templinst)_ZTSSt8iteratorISt20forward_iterator_tagN8pkgCache11PackageFileE[il]PS2_RS2_E@Base
 1.1.0
- 
(regex|optional=templinst)_ZTSSt8iteratorISt20forward_iterator_tagN8pkgCache7PackageE[il]PS2_RS2_E@Base
 1.1.0
- 
(regex|optional=templinst)_ZTSSt8iteratorISt20forward_iterator_tagN8pkgCache7VerFileE[il]PS2_RS2_E@Base
 1.1.0
- 
(regex|optional=templinst)_ZTSSt8iteratorISt20forward_iterator_tagN8pkgCache7VersionE[il]PS2_RS2_E@Base
 1.1.0
- 
(regex|optional=templinst)_ZTSSt8iteratorISt20forward_iterator_tagN8pkgCache8DescFileE[il]PS2_RS2_E@Base
 1.1.0
- 
(regex|optional=templinst)_ZTSSt8iteratorISt20forward_iterator_tagN8pkgCache8ProvidesE[il]PS2_RS2_E@Base
 1.1.0
+#MISSING: 1.3.0-2# 
(regex|optional=templinst)_ZTSSt8iteratorISt20forward_iterator_tagN8pkgCache10DependencyE[il]PS2_RS2_E@Base
 1.1.0
+#MISSING: 1.3.0-2# 
(regex|optional=templinst)_ZTSSt8iteratorISt20forward_iterator_tagN8pkgCache11PackageFileE[il]PS2_RS2_E@Base
 1.1.0
+#MISSING: 1.3.0-2# 
(regex|optional=templinst)_ZTSSt8iteratorISt20forward_iterator_tagN8pkgCache7PackageE[il]PS2_RS2_E@Base
 1.1.0
+#MISSING: 1.3.0-2# 
(regex|optional=templinst)_ZTSSt8iteratorISt20forward_iterator_tagN8pkgCache7VerFileE[il]PS2_RS2_E@Base
 1.1.0
+#MISSING: 1.3.0-2# 
(regex|optional=templinst)_ZTSSt8iteratorISt20forward_iterator_tagN8pkgCache7VersionE[il]PS2_RS2_E@Base
 1.1.0
+#MISSING: 1.3.0-2# 
(regex|optional=templinst)_ZTSSt8iteratorISt20forward_iterator_tagN8pkgCache8DescFileE[il]PS2_RS2_E@Base
 1.1.0
+#MISSING: 1.3.0-2# 
(regex|optional=templinst)_ZTSSt8iteratorISt20forward_iterator_tagN8pkgCache8ProvidesE[il]PS2_RS2_E@Base
 1.1.0
  _ZTVN4QApt5CacheE@Base 0.3.0
  _ZTVN4QApt6ConfigE@Base 1.0.60
  _ZTVN4QApt7BackendE@Base 0.3.0
dh_makeshlibs: failing due to earlier errors
make: *** [binary-arch] Error 2
dpkg-buildpackage: error: fakeroot debian/rules binary-arch gave error exit 
status 2

--- End Message ---
--- Begin Message ---
Source: qapt
Source-Version: 1.3.0-2.1

We believe that the bug you reported is fixed in the latest version of
qapt, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 746...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Matthias Klose <d...@debian.org> (supplier of updated qapt package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Sat, 09 Aug 2014 12:39:10 +0200
Source: qapt
Binary: libqapt1 libqapt-dev libqapt-runtime qapt-utils qapt-batch 
qapt-deb-installer plasma-runner-installer kde-thumbnailer-deb 
gstreamer0.10-qapt qapt-dbg
Architecture: source amd64
Version: 1.3.0-2.1
Distribution: unstable
Urgency: medium
Maintainer: Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org>
Changed-By: Matthias Klose <d...@debian.org>
Description:
 gstreamer0.10-qapt - GStreamer plugin to install codecs using QApt
 kde-thumbnailer-deb - KDE plugin to show thumbnails of Debian package files
 libqapt-dev - Development headers for the QApt library
 libqapt-runtime - Runtime components for the QApt library
 libqapt1   - QApt library package
 plasma-runner-installer - KRunner plugin for installing packages
 qapt-batch - Batch package manager for KDE
 qapt-dbg   - QApt debugging symbols
 qapt-deb-installer - tool for installing deb files
 qapt-utils - complete collection of QApt package management utilities
Closes: 746263 746894
Changes:
 qapt (1.3.0-2.1) unstable; urgency=medium
 .
   * Non-maintainer upload.
   * Update the symbols file (Xilin Sun). Closes: #746894, #746263.
Checksums-Sha1:
 f42593cc8ff26c0165db2b056d6038cb499952fb 2062 qapt_1.3.0-2.1.dsc
 bd6e0af52719a9c26905809f32471d4279eeeffd 7793 qapt_1.3.0-2.1.debian.tar.bz2
 0b2c42a2c599f6199fd627840e9a2d00a59dd0bf 106804 libqapt1_1.3.0-2.1_amd64.deb
 da6e4577c33181b47bbdc6423224029da7dca05c 27914 libqapt-dev_1.3.0-2.1_amd64.deb
 c2c847c2dabfa738558aa0c6df9cd4e430efa4b5 46300 
libqapt-runtime_1.3.0-2.1_amd64.deb
 4eaeee557423559b630367e981acd06d9d579158 10392 qapt-utils_1.3.0-2.1_amd64.deb
 f7dacaec06bb05eff9e399bfc94dfb838eb2adc9 72652 qapt-batch_1.3.0-2.1_amd64.deb
 c318c6949266a4657e510bc8d00af79b122a3e17 50362 
qapt-deb-installer_1.3.0-2.1_amd64.deb
 8765a0008c398046b662b07297605db70d1e6108 25664 
plasma-runner-installer_1.3.0-2.1_amd64.deb
 4d420a6a2f26477d14c43a7c7ab0b6121ded130e 15390 
kde-thumbnailer-deb_1.3.0-2.1_amd64.deb
 88692bcd3ea4bfbaabd98f947774eac17b15fffa 74640 
gstreamer0.10-qapt_1.3.0-2.1_amd64.deb
 d74516595468aa9e163a857e631a5c3d01668f26 3171520 qapt-dbg_1.3.0-2.1_amd64.deb
Checksums-Sha256:
 b361c8ce1074c55a4277d966015e69883e93079a06341a2c92466c08107a5644 2062 
qapt_1.3.0-2.1.dsc
 593fddf2422b6dd52fdc33bb401c159aadfab408628cb7fb2a477f9f78742773 7793 
qapt_1.3.0-2.1.debian.tar.bz2
 52c79f8828c44df4f2a8f81be87d61d05561e040e48d4d5145b0c1117e683270 106804 
libqapt1_1.3.0-2.1_amd64.deb
 d2742db0819ccb79a111d921077f885e19503532e161346dc30b77bc343c6dd8 27914 
libqapt-dev_1.3.0-2.1_amd64.deb
 4c1eb25ccb777a32e146bb335f532ea81462b20f1ba0d11574c896e890a07471 46300 
libqapt-runtime_1.3.0-2.1_amd64.deb
 2b613e42dd178cd9a17806c620b222137566d392b0b719e65b5a4ae668363d00 10392 
qapt-utils_1.3.0-2.1_amd64.deb
 60a3efe1c121e6dfea11637f42a2b3fcbb9910ab0439f466e665258293b65bb4 72652 
qapt-batch_1.3.0-2.1_amd64.deb
 1ce862c8019f630c3ca0e2eddb46f40a505878979aaa49a16558fb3a95a92e55 50362 
qapt-deb-installer_1.3.0-2.1_amd64.deb
 fbc18c8829a8dd112c9cf16a7a34709a6919af8a7b218d1dce27a8317d2695a4 25664 
plasma-runner-installer_1.3.0-2.1_amd64.deb
 fc6f3dbdd263f184d0ec2ff0e9291126f98537ade0335531f49b05685e47a9e8 15390 
kde-thumbnailer-deb_1.3.0-2.1_amd64.deb
 353186bdab44455a9f9b6ff0c4961428627f9081322a4be316331e2589767148 74640 
gstreamer0.10-qapt_1.3.0-2.1_amd64.deb
 da01b41a11d4fa1e6974592ef4dc5a317713843a89b0d5f353363d21fc37fb86 3171520 
qapt-dbg_1.3.0-2.1_amd64.deb
Files:
 bd3076a60c20c71991e19ab972e95eb4 106804 kde optional 
libqapt1_1.3.0-2.1_amd64.deb
 3941abf0f64309dbbdf8b4f535b886d5 27914 libdevel optional 
libqapt-dev_1.3.0-2.1_amd64.deb
 edb73928c594fbe32738cf86cb078f44 46300 kde optional 
libqapt-runtime_1.3.0-2.1_amd64.deb
 1055b53361a11a3b8b8053e90d575a2b 10392 kde optional 
qapt-utils_1.3.0-2.1_amd64.deb
 5e7107e34d33de1a4774017bc77b15ed 72652 kde optional 
qapt-batch_1.3.0-2.1_amd64.deb
 f896c4909b86a93abe3c1b4cf8501412 50362 kde optional 
qapt-deb-installer_1.3.0-2.1_amd64.deb
 54d8b673b62a32804655f5ae6b014019 25664 kde optional 
plasma-runner-installer_1.3.0-2.1_amd64.deb
 335d930f5f759012eab06b2b4d2dc878 15390 kde optional 
kde-thumbnailer-deb_1.3.0-2.1_amd64.deb
 741992636da8c85ddaa9d6a6f6dbd348 74640 kde optional 
gstreamer0.10-qapt_1.3.0-2.1_amd64.deb
 9acb989ee4acf59d47e2c4406d1cf4ff 3171520 debug extra 
qapt-dbg_1.3.0-2.1_amd64.deb
 d8982470470da9eedb327d5831568003 2062 kde optional qapt_1.3.0-2.1.dsc
 97bade645a0d927beef958b2eb9715d1 7793 kde optional 
qapt_1.3.0-2.1.debian.tar.bz2

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iEYEARECAAYFAlPniwgACgkQStlRaw+TLJyQXwCcD4Cmz0ZoAcMo4MSbZ5giD0OR
njcAoJqTPsaCQAGrBVLYTOXHd2bY+J36
=FkCF
-----END PGP SIGNATURE-----

--- End Message ---
_______________________________________________
pkg-kde-extras mailing list
pkg-kde-extras@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-kde-extras

Reply via email to