I have further investigated this bug:

A. What happens is that when the splashscreen hits "Initializing main view", the dots are frozen and after that, nothing will appear.

B. I've removed my digikam databases but this won't change anything

C. With a fresh new user created for purpose, I have exactly the same problem. It means, to my eyes, that it's not a problem of corrupted database or config (my databases have been checked with sqlite3, by the way, both integrities are OK).

D. When running digikam from the console, the last lines before the program hangs are:

(digikam:22956): GLib-GObject-WARNING **: cannot register existing type 'GstObject'



(digikam:22956): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed



(digikam:22956): GLib-GObject-CRITICAL **: g_type_register_static: assertion 'parent_type > 0' failed



(digikam:22956): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

(digikam:22956): GStreamer-CRITICAL **: gst_plugin_feature_get_name: assertion 'GST_IS_PLUGIN_FEATURE (feature)' failed


E. I've tried to install digikam 4.2.0 from ubuntu, it hangs at exactly the same moment.

So I suspect it's a recent shared library update which is the culprit.

As a matter of fact, I can't access to digikam anymore. It will NEVER pass that "initializing main view" message.

Hope this gets solved soon as I use Digikam on a daily basis.

Thank you

regards

Massis

_______________________________________________
pkg-kde-extras mailing list
pkg-kde-extras@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-kde-extras

Reply via email to