Hi,

This package appears to have a trigger cycle causing upgrade issues from
Wheezy to Jessie.  To fix this issue, you need upload a patched version
without this cycle *and* dpkg needs to be upgraded prior to your
package.  The latter is solved by making dpkg "Breaks" your package.

I have requested that the dpkg maintainers go ahead and add the Breaks
on their next upload - meaning *this package may become uninstallable in
unstable in the near future*.  This request was based on the assumption
that the upload will fix some of them outstanding upgrade issues (see
our Jenkins upgrade tests[1][2])

To my knowledge the affected packages are:

 * auctex - key package (i.e. no automatic removal)
 * wordpress - to be automatically removed on January 24th.
   - Craig: I am aware of the version in NEW.  However, given it is
     in NEW, I doubt it will comply with the freeze policy.  Do contact
     the release team if you believe otherwise.
 * gxine - to be automatically removed on January 9th.
 * icecc - to be automatically removed on January 24th.

I strongly urge you to resolve the trigger issue really soon now.  For
the non-key packages, they *will be manually removed from testing* if
they stall the dpkg migrating to testing *on (or after) January 5th*.
  For auctex, I am pondering between an NMU or manual removal as well
depending on the fallout of removing the package.  Please consider this
mail an "/intend to NMU/ switching to no-await triggers".

If you already know what the resolution is for your bug, but simply do
not have time to implement it before January 5th then - *promptly*
follow up to the bug affecting your package *CC'ing me* explaining the
desired solution and including a permission for an NMU to implement this
solution.

I apologise for the short notice and for the rather resolute mail.
However, I strongly believe that we need to resolve the Jessie upgrade
issues sooner rather than later - especially considering we are not soon
two months into the freeze.

As a minor band-aid - If your package is manually removed *before* the
date set by the automatic removal tool (see above), your deadline for
getting your package back in testing is 7 days after the date set above
*OR* February 5th (whichever comes first).  For auctex (assuming it is
removed), the deadline will be February 5th.
  Please see the freeze policy[3] for the details of getting your
package back into testing.  If you want to make use of this "extended
deadline", please remember to quote this mail when doing so.

Thanks for your understanding,
~Niels

[1]
https://jenkins.debian.net/job/chroot-installation_wheezy_bootstrap_upgrade_to_jessie/

[2]
https://jenkins.debian.net/job/chroot-installation_wheezy_bootstrap_upgrade_to_jessie_aptdpkg_first/

[3] https://release.debian.org/jessie/freeze_policy.html

_______________________________________________
pkg-kde-extras mailing list
pkg-kde-extras@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-kde-extras

Reply via email to