Package: plasma-nm
Version: 0.9.3.4-2
Severity: normal
Tags: newcomer

Dear Maintainer,

*** Reporter, please consider answering these questions, where appropriate ***

   * What led up to the situation?
I tried to a CVPN-Connection in the Connection Editor.
Kwallet dialoge promted me for the password.
The connection-form loaded in the background.
Password was entered into kwallet.
Focus got shifted to the Connection-Editor.
I close the connection editor.
Again rightclick > edit … (with open kwallet)
-> Segmentation fault
   * What exactly did you do (or not do) that was effective (or
     ineffective)?
   * What was the outcome of this action?
Ausführbare Datei: kde-nm-connection-editor PID: 21734 Signal: Segmentation
fault (11) Datum: 04.02.2015 14:34:16

Application: Verbindungs-Editor (kde-nm-connection-editor), signal:
Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[KCrash Handler]
#5  0x00007fd3a3367166 in ConnectionDetailEditor::gotSecrets(QString const&,
bool, QMap<QString, QMap<QString, QVariant> > const&, QString const&) () from
/usr/lib/libplasmanetworkmanagement-editor.so
#6  0x00007fd3a2767f4c in QMetaObject::activate(QObject*, QMetaObject const*,
int, void**) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7  0x00007fd3a2fdcb4d in NetworkManager::Connection::gotSecrets(QString
const&, bool, QMap<QString, QMap<QString, QVariant> > const&, QString const&)
() from /usr/lib/x86_64-linux-gnu/libNetworkManagerQt.so.1
#8  0x00007fd3a2fdd4d0 in
NetworkManager::Connection::onSecretsArrived(QDBusPendingCallWatcher*) () from
/usr/lib/x86_64-linux-gnu/libNetworkManagerQt.so.1
#9  0x00007fd3a2767f4c in QMetaObject::activate(QObject*, QMetaObject const*,
int, void**) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#10 0x00007fd3a2d5fdcf in
QDBusPendingCallWatcher::finished(QDBusPendingCallWatcher*) () from
/usr/lib/x86_64-linux-gnu/libQtDBus.so.4
#11 0x00007fd3a276c641 in QObject::event(QEvent*) () from /usr/lib/x86_64
-linux-gnu/libQtCore.so.4
#12 0x00007fd3a096b29c in QApplicationPrivate::notify_helper(QObject*, QEvent*)
() from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#13 0x00007fd3a0971da8 in QApplication::notify(QObject*, QEvent*) () from
/usr/lib/x86_64-linux-gnu/libQtGui.so.4
#14 0x00007fd3a1f0e2ca in KApplication::notify(QObject*, QEvent*) () from
/usr/lib/libkdeui.so.5
#15 0x00007fd3a2752f8d in QCoreApplication::notifyInternal(QObject*, QEvent*)
() from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#16 0x00007fd3a2756821 in QCoreApplicationPrivate::sendPostedEvents(QObject*,
int, QThreadData*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#17 0x00007fd3a27823a3 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#18 0x00007fd39e11cc5d in g_main_context_dispatch () from /lib/x86_64-linux-
gnu/libglib-2.0.so.0
#19 0x00007fd39e11cf48 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007fd39e11cffc in g_main_context_iteration () from /lib/x86_64-linux-
gnu/libglib-2.0.so.0
#21 0x00007fd3a27824ed in
QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) ()
from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#22 0x00007fd3a0a0fb96 in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#23 0x00007fd3a2751ae1 in
QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from
/usr/lib/x86_64-linux-gnu/libQtCore.so.4
#24 0x00007fd3a2751e45 in
QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64
-linux-gnu/libQtCore.so.4
#25 0x00007fd3a27578b9 in QCoreApplication::exec() () from /usr/lib/x86_64
-linux-gnu/libQtCore.so.4
#26 0x0000000000409f25 in ?? ()
#27 0x00007fd39f4b3b45 in __libc_start_main (main=0x409770, argc=2,
argv=0x7fffa8166698, init=<optimized out>, fini=<optimized out>,
rtld_fini=<optimized out>, stack_end=0x7fffa8166688) at libc-start.c:287
#28 0x000000000040a044 in _start ()


   * What outcome did you expect instead?

*** End of the template - remove these template lines ***



-- System Information:
Debian Release: 8.0
  APT prefers testing
  APT policy: (500, 'testing'), (400, 'unstable'), (300, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.18.0-trunk-amd64 (SMP w/8 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages plasma-nm depends on:
ii  kde-runtime                     4:4.14.2-2
ii  libc6                           2.19-14
ii  libgcc1                         1:4.9.1-19
ii  libkdecore5                     4:4.14.2-4
ii  libkdeui5                       4:4.14.2-4
ii  libkio5                         4:4.14.2-4
ii  libknotifyconfig4               4:4.14.2-4
ii  libmodemmanagerqt1              1.0.1-2
ii  libnetworkmanagerqt1            0.9.8.2-1
ii  libopenconnect3                 6.00-1+b1
ii  libplasma3                      4:4.14.2-4
ii  libqt4-dbus                     4:4.8.6+git64-g5dc8b2b+dfsg-2+b1
ii  libqt4-declarative              4:4.8.6+git64-g5dc8b2b+dfsg-2+b1
ii  libqt4-network                  4:4.8.6+git64-g5dc8b2b+dfsg-2+b1
ii  libqt4-svg                      4:4.8.6+git64-g5dc8b2b+dfsg-2+b1
ii  libqt4-xml                      4:4.8.6+git64-g5dc8b2b+dfsg-2+b1
ii  libqtcore4                      4:4.8.6+git64-g5dc8b2b+dfsg-2+b1
ii  libqtgui4                       4:4.8.6+git64-g5dc8b2b+dfsg-2+b1
ii  libsolid4                       4:4.14.2-4
ii  libstdc++6                      4.9.1-19
ii  mobile-broadband-provider-info  20140317-1
ii  network-manager                 1.0.0-2

Versions of packages plasma-nm recommends:
ii  kwalletmanager           4:4.14.2-1
ii  network-manager-openvpn  1.0.0-1
ii  network-manager-pptp     1.0.0-1
ii  network-manager-vpnc     1.0.0-1

Versions of packages plasma-nm suggests:
ii  kde-workspace-bin            4:4.11.13-2
ii  network-manager-openconnect  0.9.10.0-1

-- no debconf information

_______________________________________________
pkg-kde-extras mailing list
pkg-kde-extras@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-kde-extras

Reply via email to