Your message dated Mon, 18 May 2015 19:24:37 -0700
with message-id <6423096.SaUrpHLEvi@myrada>
and subject line Re: konversation: Hard dependency on a complete pim stack
has caused the Debian Bug report #631158,
regarding konversation: Hard dependency on a complete pim stack
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
631158: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=631158
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: konversation
Version: 1.3.1+git264+g6dfad44-1
Severity: normal

Hi,

I was quite amazed today to see that an IRC app has a hard dependency on
kdepim-runtime, which effectively means requiring a complete pim stack
(except for the actual pim-apps like kmail or kontact). I can certainly
understand that kdepim provides features that konversation wishes to
use, but I don't think it'll completely break down if the package is not
installed. So I think it would be better to mark kdepim-runtime as a
recommends instead of a Depends.

Andreas

-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (500, 'stable'), (1, 
'experimental')
Architecture: i386 (i686)

Kernel: Linux 2.6.38-2-686-bigmem (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages konversation depends on:
ii  kdebase-runtime  4:4.6.2-1               runtime components from the offici
ii  kdepim-runtime   4:4.4.11.1-1            Runtime components for akonadi-kde
ii  konversation-dat 1.3.1+git264+g6dfad44-1 data files for Konversation
ii  libc6            2.13-4                  Embedded GNU C Library: Shared lib
ii  libgcc1          1:4.6.0-8               GCC support library
ii  libkabc4         4:4.6.2-1               library for handling address book 
ii  libkde3support4  4:4.6.2-1               KDE 3 Support Library for the KDE 
ii  libkdecore5      4:4.6.2-1               KDE Platform Core Library
ii  libkdeui5        4:4.6.2-1               KDE Platform User Interface Librar
ii  libkio5          4:4.6.2-1               Network-enabled File Management Li
ii  libknotifyconfig 4:4.6.2-1               library for configuring KDE Notifi
ii  libkparts4       4:4.6.2-1               Framework for the KDE Platform Gra
ii  libkresources4   4:4.6.2-1               KDE Resource framework library
ii  libkutils4       4:4.6.2-1               dummy transitional library
ii  libphonon4       4:4.6.0really4.5.0-3    multimedia framework from KDE - co
ii  libqca2          2.0.2-1                 libraries for the Qt Cryptographic
ii  libqt4-dbus      4:4.7.3-1               Qt 4 D-Bus module
ii  libqt4-network   4:4.7.3-1               Qt 4 network module
ii  libqt4-qt3suppor 4:4.7.3-1               Qt 3 compatibility library for Qt 
ii  libqt4-svg       4:4.7.3-1               Qt 4 SVG module
ii  libqt4-xml       4:4.7.3-1               Qt 4 XML module
ii  libqtcore4       4:4.7.3-1               Qt 4 core module
ii  libqtgui4        4:4.7.3-1               Qt 4 GUI module
ii  libsolid4        4:4.6.2-1               Solid Library for KDE Platform
ii  libstdc++6       4.6.0-8                 The GNU Standard C++ Library v3
ii  phonon           4:4.6.0really4.5.0-3    multimedia framework from KDE - me

konversation recommends no packages.

konversation suggests no packages.

-- no debconf information



--- End Message ---
--- Begin Message ---
tag:wontfix

I was looking through konversation bugs and discovered this old bug.

The dependency on kdepim is a requirement chosen by the konversation project, 
as they probably wanted to link IRC nicks with the kde addressbook

There's not a lot that can be done about it, other than use a different IRC 
client. 

(If you're interested The CMake build instructions for konversation declare  
kdepim as required can be seen here:

http://sources.debian.net/src/konversation/1.5-2/CMakeLists.txt/#L9

Diane Trout 

On Mon, 20 Jun 2011 23:09:13 +0200 Andreas Pakulat <ap...@gmx.de> wrote:
> Package: konversation
> Version: 1.3.1+git264+g6dfad44-1
> Severity: normal
> 
> Hi,
> 
> I was quite amazed today to see that an IRC app has a hard dependency on
> kdepim-runtime, which effectively means requiring a complete pim stack
> (except for the actual pim-apps like kmail or kontact). I can certainly
> understand that kdepim provides features that konversation wishes to
> use, but I don't think it'll completely break down if the package is not
> installed. So I think it would be better to mark kdepim-runtime as a
> recommends instead of a Depends.
> 

--- End Message ---
_______________________________________________
pkg-kde-extras mailing list
pkg-kde-extras@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-kde-extras

Reply via email to