I took a crack at this but I'm not sure I'm using the right build environment
since I'm seeing a different build error. FWIW, when building in a sid chroot
with gcc-5 and g++-5 (5.1.1-14) I get:

1) Several build warnings:
In file included from /usr/include/xapian.h:40:0,
                 from /tmp/buildd/qapt-1.3.0/src/backend.cpp:44:
/usr/include/xapian/version.h:29:2: warning: #warning The C++ ABI version of
compiler you are using does not exactly match [-Wcpp]
 #warning The C++ ABI version of compiler you are using does not exactly match
  ^
/usr/include/xapian/version.h:30:2: warning: #warning that of the compiler used
to build the library. If linking fails [-Wcpp]
 #warning that of the compiler used to build the library. If linking fails
  ^
/usr/include/xapian/version.h:31:2: warning: #warning due to missing symbols,
this is probably the reason why. [-Wcpp]
 #warning due to missing symbols, this is probably the reason why.
  ^
/usr/include/xapian/version.h:32:2: warning: #warning The Xapian library was
built with g++ 4.9.2 [-Wcpp]
 #warning The Xapian library was built with g++ 4.9.2
  ^

These don't cause build failures though.


2) Build errors:
In file included from 
/tmp/buildd/qapt-1.3.0/utils/qapt-batch/qaptbatch.cpp:490:0:
/tmp/buildd/qapt-1.3.0/obj-x86_64-linux-gnu/utils/qapt-batch/qaptbatch.moc:15:2:
error: #error "This file was generated using the moc from 5.4.2. It"
 #error "This file was generated using the moc from 5.4.2. It"
  ^
/tmp/buildd/qapt-1.3.0/obj-x86_64-linux-gnu/utils/qapt-batch/qaptbatch.moc:16:2:
error: #error "cannot be used with the include files from this version of Qt."
 #error "cannot be used with the include files from this version of Qt."
  ^
/tmp/qapt-1.3.0/obj-x86_64-linux-gnu/utils/qapt-batch/qaptbatch.moc:17:2: error:
#error "(The moc has changed too much.)"
 #error "(The moc has changed too much.)"

For some reason cmake uses the moc from qt5 for ./utils instead of the moc from
qt4. It uses the correct moc for ./src though. I'm not familiar with cmake so
don't know why that is. Cmake seems to get confused because qt5-make is also
installed which is pulled in through the build dependency libdebconf-kde-dev. I
get past the error if I change that dependency to libdebconf-kde0-dev.


3) Subsequent build error:
dpkg-gensymbols: warning: some symbols or patterns disappeared in the symbols
file: see diff output below
dpkg-gensymbols: warning: debian/libqapt1/DEBIAN/symbols doesn't match
completely debian/libqapt1.symbols
--- debian/libqapt1.symbols (libqapt1_1.3.0-2.1_amd64)
+++ dpkg-gensymbolsaXl2cU       2015-07-28 09:43:03.940335095 +0000
@@ -125,8 +125,8 @@
  _ZN4QApt9ChangelogD1Ev@Base 1.3.0
  _ZN4QApt9ChangelogD2Ev@Base 1.3.0
  _ZN4QApt9ChangelogaSERKS0_@Base 1.3.0
- _ZN6Xapian5ErrorD1Ev@Base 1.3.0
- _ZN6Xapian5ErrorD2Ev@Base 1.3.0
+#MISSING: 1.3.0-2.1# _ZN6Xapian5ErrorD1Ev@Base 1.3.0
+#MISSING: 1.3.0-2.1# _ZN6Xapian5ErrorD2Ev@Base 1.3.0
  _ZNK4QApt11HistoryItem11errorStringEv@Base 1.0.80
  _ZNK4QApt11HistoryItem14purgedPackagesEv@Base 1.0.80
  _ZNK4QApt11HistoryItem15removedPackagesEv@Base 1.0.80
dh_makeshlibs: failing due to earlier errors

Not sure if this is a gcc5-specific error or if it's related to the xapian
warnings. However, with the following patch, I'm able to successfully build the
package:


diff --git a/debian/control b/debian/control
index 32c469c..b03cca1 100644
--- a/debian/control
+++ b/debian/control
@@ -14,7 +14,7 @@ Build-Depends: debhelper (>= 9),
  libxapian-dev,
  libpolkit-qt-1-dev,
  libqtgstreamer-dev,
- libdebconf-kde-dev
+ libdebconf-kde0-dev
 Standards-Version: 3.9.3.1
 Homepage: https://projects.kde.org/projects/extragear/sysadmin/libqapt/
 Vcs-Git: git://anonscm.debian.org/pkg-kde/kde-extras/qapt.git
diff --git a/debian/libqapt1.symbols b/debian/libqapt1.symbols
index 8259e12..5f81abb 100644
--- a/debian/libqapt1.symbols
+++ b/debian/libqapt1.symbols
@@ -125,8 +125,6 @@ libqapt.so.1 libqapt1 #MINVER#
  _ZN4QApt9ChangelogD1Ev@Base 1.3.0
  _ZN4QApt9ChangelogD2Ev@Base 1.3.0
  _ZN4QApt9ChangelogaSERKS0_@Base 1.3.0
- _ZN6Xapian5ErrorD1Ev@Base 1.3.0
- _ZN6Xapian5ErrorD2Ev@Base 1.3.0
  _ZNK4QApt11HistoryItem11errorStringEv@Base 1.0.80
  _ZNK4QApt11HistoryItem14purgedPackagesEv@Base 1.0.80
  _ZNK4QApt11HistoryItem15removedPackagesEv@Base 1.0.80


--
Juerg Haefliger
Hewlett-Packard

_______________________________________________
pkg-kde-extras mailing list
pkg-kde-extras@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-kde-extras

Reply via email to