Your message dated Tue, 28 Jul 2015 14:51:54 +0300
with message-id <1750431438084...@web6m.yandex.ru>
and subject line Re: Bug#793869: libqtcurve-utils2: fails to install, trying to 
overwrite other packages files: 
/usr/lib/x86_64-linux-gnu/libqtcurve-utils.so.2.0
has caused the Debian Bug report #793869,
regarding libqtcurve-utils2: fails to install, trying to overwrite other 
packages files: /usr/lib/x86_64-linux-gnu/libqtcurve-utils.so.2.0
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
793869: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=793869
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: libqtcurve-utils2
Version: 1.8.18+git20150711-a3fff13-3
Severity: serious
User: debian...@lists.debian.org
Usertags: piuparts

Hi,

during a test with piuparts I noticed your package failed to install
because it tries to overwrite other packages files without declaring a
Breaks+Replaces relation.

See policy 7.6 at
https://www.debian.org/doc/debian-policy/ch-relationships.html#s-replaces

>From the attached log (scroll to the bottom...):

  Selecting previously unselected package libqtcurve-utils2:amd64.
  (Reading database ... 7851 files and directories currently installed.)
  Preparing to unpack 
.../libqtcurve-utils2_1.8.18+git20150711-a3fff13-3_amd64.deb ...
  Unpacking libqtcurve-utils2:amd64 (1.8.18+git20150711-a3fff13-3) ...
  dpkg: error processing archive 
/var/cache/apt/archives/libqtcurve-utils2_1.8.18+git20150711-a3fff13-3_amd64.deb
 (--unpack):
   trying to overwrite '/usr/lib/x86_64-linux-gnu/libqtcurve-utils.so.2.0', 
which is also in package libqtcurve-utils1:amd64 1.8.18+git20150711-a3fff13-2
  Errors were encountered while processing:
   
/var/cache/apt/archives/libqtcurve-utils2_1.8.18+git20150711-a3fff13-3_amd64.deb


You'll probably need

  Package:  libqtcurve-utils2
  Breaks:   libqtcurve-utils1 (>= $VER~)
  Replaces: libqtcurve-utils1 (>= $VER~)

where $VER is the version that incorrectly bumped the soname inside 
libqtcurve-utils1.


cheers,

Andreas

Attachment: libqtcurve-utils1=1.8.18+git20150711-a3fff13-2_libqtcurve-utils2=1.8.18+git20150711-a3fff13-3.log.gz
Description: application/gzip


--- End Message ---
--- Begin Message ---
Hi,

> during a test with piuparts I noticed your package failed to install
> because it tries to overwrite other packages files without declaring a
> Breaks+Replaces relation.
>
> See policy 7.6 at
> https://www.debian.org/doc/debian-policy/ch-relationships.html#s-replaces
>
>> From the attached log (scroll to the bottom...):
>
>   Selecting previously unselected package libqtcurve-utils2:amd64.
>   (Reading database ... 7851 files and directories currently installed.)
>   Preparing to unpack 
> .../libqtcurve-utils2_1.8.18+git20150711-a3fff13-3_amd64.deb ...
>   Unpacking libqtcurve-utils2:amd64 (1.8.18+git20150711-a3fff13-3) ...
>   dpkg: error processing archive 
> /var/cache/apt/archives/libqtcurve-utils2_1.8.18+git20150711-a3fff13-3_amd64.deb
>  (--unpack):
>    trying to overwrite '/usr/lib/x86_64-linux-gnu/libqtcurve-utils.so.2.0', 
> which is also in package libqtcurve-utils1:amd64 1.8.18+git20150711-a3fff13-2
>   Errors were encountered while processing:
>    
> /var/cache/apt/archives/libqtcurve-utils2_1.8.18+git20150711-a3fff13-3_amd64.deb
>
> You'll probably need
>
>   Package: libqtcurve-utils2
>   Breaks: libqtcurve-utils1 (>= $VER~)
>   Replaces: libqtcurve-utils1 (>= $VER~)
>
> where $VER is the version that incorrectly bumped the soname inside 
> libqtcurve-utils1.


Thank you for a bug report. But unfortunately it is invalid:
1) Package libqtcurve-utils1 was never part of Debian stable, testing or
   unstable. It was available only in Debian experimental.
2) Updating qtcurve packages from previous version in unstable to
   1.8.18+git20150711-a3fff13-4 is smooth.
3) As for users of qtcurve packages in Debian experimental, they may face with
   this problem only during updating from 1.8.18+git20150711-a3fff13-1 and
   1.8.18+git20150711-a3fff13-2 versions. If they use 1.8.18-3 or any earlier
   version updating will be smooth for them.
4) Version 1.8.18+git20150711-a3fff13-1 was uploaded 2015-07-26 and version
   1.8.18+git20150711-a3fff13-3 has passed NEW queue 2015-07-27, so the number
   of possibly affected users is close to zero.

-- 
Best regards,
Boris

--- End Message ---
_______________________________________________
pkg-kde-extras mailing list
pkg-kde-extras@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-kde-extras

Reply via email to