Package: digikam
Version: 4:4.14.0-3
Severity: important

Dear Maintainer,


* What led up to the situation?

adding/removing a tag to a photo.
   
* What exactly did you do (or not do) that was effective (or
  ineffective)?

Updating digikam to 4.14.0, updating Debian to "stretch".

1. Open digikam (with a large collection that used to work before the update)
2. Open an album
3. Select a photography
4. Open the labels/tags sidebar
5. Add a tag or remove a tag
6. Press "Apply" or move selection to the next photography.
     
* What was the outcome of this action?

digikam crashed with

digikam: tiffcomposite.cpp:749: virtual Exiv2::Internal::TiffComponent* 
Exiv2::Internal::TiffMnEntry::doAddPath(uint16_t, Exiv2::Internal::TiffPath&, 
Exiv2::Internal::TiffComponent*, Exiv2::Internal::TiffComponent::AutoPtr): 
Zusicherung »mn_« nicht erfüllt.
digikam: Fatal IO error: client killed

(After re-opening digikam, the tag was set/removed.)

* What outcome did you expect instead?

No crash, just setting/removing the tag.



The issue also manifested when editing an image, i.e. replacing
4 to 6 above with

4. open the image in the editor (F4)
5. some edit
6. save new version

crash.




-- System Information:
Debian Release: stretch/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.3.0-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages digikam depends on:
ii  digikam-data            4:4.14.0-3
ii  digikam-private-libs    4:4.14.0-3
ii  kde-runtime             4:15.08.3-1
ii  libc6                   2.21-7
ii  libgcc1                 1:5.3.1-7
ii  libgphoto2-6            2.5.9-3
ii  libgphoto2-port12       2.5.9-3
ii  libkdcraw23             4:15.08.0-1+b1
ii  libkdecore5             4:4.14.14-1+b1
ii  libkdeui5               4:4.14.14-1+b1
ii  libkexiv2-11            4:15.04.3-1
ii  libkhtml5               4:4.14.14-1+b1
ii  libkio5                 4:4.14.14-1+b1
ii  libkipi11               4:15.08.3-1
ii  libknotifyconfig4       4:4.14.14-1+b1
ii  libkparts4              4:4.14.14-1+b1
ii  libopencv-core2.4v5     2.4.9.1+dfsg-1.2
ii  libopencv-imgproc2.4v5  2.4.9.1+dfsg-1.2
ii  libphonon4              4:4.8.3-2
ii  libqt4-dbus             4:4.8.7+dfsg-5
ii  libqt4-sql              4:4.8.7+dfsg-5
ii  libqt4-sql-sqlite       4:4.8.7+dfsg-5
ii  libqt4-xml              4:4.8.7+dfsg-5
ii  libqtcore4              4:4.8.7+dfsg-5
ii  libqtgui4               4:4.8.7+dfsg-5
ii  libsolid4               4:4.14.14-1+b1
ii  libstdc++6              5.3.1-7
ii  libthreadweaver4        4:4.14.14-1+b1
ii  perl                    5.22.1-4
ii  phonon                  4:4.8.3-2

Versions of packages digikam recommends:
ii  chromium [www-browser]   47.0.2526.80-1~deb8u1
ii  dillo [www-browser]      3.0.5-1+b1
ii  elinks [www-browser]     0.12~pre6-11+b2
ii  iceweasel [www-browser]  43.0.4-1
ii  kipi-plugins             4:4.14.0-3
ii  midori [www-browser]     0.5.11-ds1-2
ii  mplayerthumbs            4:15.08.3-1

Versions of packages digikam suggests:
ii  digikam-doc     4:4.4.0-1.1
ii  systemsettings  4:5.4.3-1

-- no debconf information

_______________________________________________
pkg-kde-extras mailing list
pkg-kde-extras@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-kde-extras

Reply via email to