Package: amarok
Version: 2.8.0-4
Severity: important
Tags: l10n

Dear Maintainer,

The Amarok collection forgot all the songs from paths that contain special 
symbols (non-Latin, ex. /home/alex/muzică). Amarok is able to play all these 
songs, but they don't appear in the "media sources" and have no statistic 
anymore (they used to have until some tiem ago).

Reproduce:
1. Create two copies of a file and modify the tags on one of the slightly (say 
Amarok.mp3/Title, Amarok-2.mp3/Title2)
2. Create directories ~/test and ~/testă.
3. Copy first file to ~/test and the second one to ~/testă
4. Add the directories to Amarok collection and rescan.
5. Notice that the song in ~/test is added to the collection, the song in 
~/testă is not added to the collection.

This may be related to some KDE transition, because other KDE programs had 
temporary problems with paths containing non-Latin symbols (Krusader and Okular 
had this for a couple of weeks in December).


*** Reporter, please consider answering these questions, where appropriate ***

   * What led up to the situation?
   * What exactly did you do (or not do) that was effective (or
     ineffective)?
   * What was the outcome of this action?
   * What outcome did you expect instead?

*** End of the template - remove these template lines ***


-- System Information:
Debian Release: stretch/sid
  APT prefers testing
  APT policy: (900, 'testing'), (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.3.0-1-amd64 (SMP w/8 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=locale: Cannot set 
LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
ANSI_X3.4-1968)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages amarok depends on:
ii  amarok-common             2.8.0-4
ii  amarok-utils              2.8.0-4
ii  kde-runtime               4:15.12.1-1
ii  libaio1                   0.3.110-2
ii  libavcodec-ffmpeg56       7:2.8.6-1+b1
ii  libavformat-ffmpeg56      7:2.8.6-1+b1
ii  libavutil-ffmpeg54        7:2.8.6-1+b1
ii  libc6                     2.21-7
ii  libcurl3-gnutls           7.47.0-1
ii  libgcc1                   1:5.3.1-8
ii  libgcrypt20               1.6.5-2
ii  libgdk-pixbuf2.0-0        2.32.3-1.2
ii  libgl1-mesa-glx [libgl1]  11.1.2-1
ii  libglib2.0-0              2.46.2-3
ii  libgpod4                  0.8.3-5+b1
ii  libimobiledevice6         1.2.0+dfsg-2.1
ii  libkcmutils4              4:4.14.16-1
ii  libkdecore5               4:4.14.16-1
ii  libkdeui5                 4:4.14.16-1
ii  libkdewebkit5             4:4.14.16-1
ii  libkdnssd4                4:4.14.16-1
ii  libkfile4                 4:4.14.16-1
ii  libkio5                   4:4.14.16-1
ii  libknewstuff3-4           4:4.14.16-1
ii  liblastfm1                1.0.9-1
ii  libloudmouth1-0           1.5.2-1
ii  libmtp9                   1.1.10-2
ii  libmysqlclient18          5.6.28-1
ii  libnepomukcore4           4:4.14.0-1+b4
ii  libofa0                   0.9.3-10
ii  libphonon4                4:4.8.3-2
ii  libplasma3                4:4.14.16-1
ii  libqjson0                 0.8.1-3
ii  libqt4-dbus               4:4.8.7+dfsg-6
ii  libqt4-network            4:4.8.7+dfsg-6
ii  libqt4-opengl             4:4.8.7+dfsg-6
ii  libqt4-script             4:4.8.7+dfsg-6
ii  libqt4-sql                4:4.8.7+dfsg-6
ii  libqt4-svg                4:4.8.7+dfsg-6
ii  libqt4-xml                4:4.8.7+dfsg-6
ii  libqtcore4                4:4.8.7+dfsg-6
ii  libqtgui4                 4:4.8.7+dfsg-6
ii  libqtscript4-core         0.2.0-1
ii  libqtscript4-gui          0.2.0-1
ii  libqtscript4-network      0.2.0-1
ii  libqtscript4-sql          0.2.0-1
ii  libqtscript4-uitools      0.2.0-1
ii  libqtscript4-xml          0.2.0-1
ii  libqtwebkit4              2.3.4.dfsg-6
ii  libsolid4                 4:4.14.16-1
ii  libsoprano4               2.9.4+dfsg-3+b1
ii  libstdc++6                5.3.1-8
ii  libthreadweaver4          4:4.14.16-1
ii  libx11-6                  2:1.6.3-1
ii  libxml2                   2.9.3+dfsg1-1
ii  phonon                    4:4.8.3-2
ii  zlib1g                    1:1.2.8.dfsg-2+b1

Versions of packages amarok recommends:
ii  clamz        0.5-2+b1
ii  kio-audiocd  4:14.12.2-1

Versions of packages amarok suggests:
pn  amarok-doc         <none>
ii  libqt4-sql-mysql   4:4.8.7+dfsg-6
pn  libqt4-sql-psql    <none>
ii  libqt4-sql-sqlite  4:4.8.7+dfsg-6
pn  moodbar            <none>

Versions of packages amarok-common depends on:
ii  perl  5.22.1-7

amarok-common recommends no packages.

Versions of packages amarok is related to:
ii  phonon-backend-vlc [phonon-backend]  0.8.2-1

-- debconf information:
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "en_GB",
        LC_ALL = (unset),
        LANG = "en_GB.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory

_______________________________________________
pkg-kde-extras mailing list
pkg-kde-extras@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-kde-extras

Reply via email to