Package: digikam
Version: 4:5.1.0-2
Severity: important
Tags: patch

--- Please enter the report below this line. ---
Just upgraded from latest Debian Digikam version 4 (with database version 6). 
I set the path of my old database on first start and when Digikam opened there 
where no more albums in the interface.

After restoration of my old database and various tests, I discover that my 
album root path where "urlencoded" in previous version with all '/' replace by 
'%2F'. Whit such path, Digikam 5.1 does not recognize album root and remove 
all metadata from the database on albums refreshing.

To correct this, I had to edit with sqlitebrowser the file digikam4.db and in 
the table AlbumRoots, replace all occurence of '%2F' bay '/' in the field 
identifier. Then Digikam recognize the path an show all my albums, photo and 
associated metadata.

--- System information. ---
Architecture: amd64
Kernel:       Linux 4.6.0-1-amd64

Debian Release: stretch/sid
  500 unstable        http.debian.net 
  500 testing         http.debian.net 
  500 syncthing       apt.syncthing.net 
  500 stable          security.debian.org 
  500 stable          http.debian.net 
  101 experimental    http.debian.net 

--- Package information. ---
Depends                        (Version) | Installed
========================================-+-================
digikam-private-libs       (= 4:5.1.0-2) | 4:5.1.0-2
libc6                          (>= 2.14) | 
libgcc1                       (>= 1:3.0) | 
libkf5configcore5            (>= 4.97.0) | 
libkf5coreaddons5           (>= 4.100.0) | 
libkf5filemetadata3         (>= 5.1.0.1) | 
libkf5i18n5                  (>= 4.97.0) | 
libkf5xmlgui5                (>= 4.96.0) | 
libqt5core5a             (>= 5.6.0~beta) | 
libqt5gui5                    (>= 5.4.0) | 
libqt5sql5                    (>= 5.4.0) | 
libqt5widgets5                (>= 5.4.0) | 
libstdc++6                      (>= 4.9) | 
perl:any                                 | 
libqt5sql5-sqlite                        | 
digikam-data               (= 4:5.1.0-2) | 


Recommends         (Version) | Installed
============================-+-===========
www-browser                  | 
ffmpegthumbs                 | 4:16.04.2-1
 OR mplayerthumbs            | 4:15.08.3-2


Suggests            (Version) | Installed
=============================-+-===========
digikam-doc                   | 4:5.1.0-2
systemsettings                | 4:5.7.0-1





-- 
Landry MINOZA
landry.min...@gmail.com

_______________________________________________
pkg-kde-extras mailing list
pkg-kde-extras@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-kde-extras

Reply via email to