Package: digikam
Version: 4:5.2.0-2
Severity: important

Dear Maintainer,

digikam can't access my camera anymore, after upgrading to version 5.2.0-2. The
reason is that libgphoto2 support is missing in that version whereas it was
available in 5.1.0-2. This, or a similar problem, had occured a number of times
before (#785492 and #821178) and disappeared subsequently.

Comparing the build logs for 5.1.0-2:
https://buildd.debian.org/status/fetch.php?pkg=digikam&arch=amd64&ver=4%3A5.1.0-2&stamp=1471129203
and 5.2.0-2:
https://buildd.debian.org/status/fetch.php?pkg=digikam&arch=amd64&ver=4%3A5.2.0-2&stamp=1477261520
yields:

5.1:
[...]
-- libgphoto2 execurables check...
-- Found gphoto2: -lgphoto2_port;-lgphoto2 -lgphoto2_port -lm
-- libgphoto2 found: TRUE
-- Found LibUSB1: /usr/lib/x86_64-linux-gnu/libusb-1.0.so
-- LibUSB1_FOUND        = TRUE
-- LibUSB1_INCLUDE_DIRS = /usr/include/libusb-1.0
-- LibUSB1_LIBRARIES    = /usr/lib/x86_64-linux-gnu/libusb-1.0.so
-- libusb1 found: TRUE
-- Libgphoto2 and libusb1 have been found.
-- libgphoto2 API version >= 2.5
-- libgphoto2 API version found:  2.5.10
[...]
--  libgphoto2 found......................... YES (optional)
[...]

5.2:
[...]
-- Found gphoto2: /usr/lib/x86_64-linux-gnu/libgphoto2.so;/usr/lib/x86_64
-linux-gnu/libgphoto2_port.so
-- libgphoto2 found: TRUE
-- Found LibUSB1: /usr/lib/x86_64-linux-gnu/libusb-1.0.so
-- LibUSB1_FOUND        = TRUE
-- LibUSB1_INCLUDE_DIRS = /usr/include/libusb-1.0
-- LibUSB1_LIBRARIES    = /usr/lib/x86_64-linux-gnu/libusb-1.0.so
-- libusb1 found: TRUE
-- Libgphoto2 and libusb1 have been found.
-- Command gphoto2 not found. Cannot identify GPhoto2 API version.
[...]
--  libgphoto2 found......................... NO  (optional)
--  digiKam will be compiled without GPhoto2 camera drivers support.
--  Please install the libgphoto2 (version >= 2.4.0) development package.
--
[...]

I hope that helps.
Best regards,

Andreas



-- System Information:
Debian Release: stretch/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.7.0-1-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages digikam depends on:
ii  digikam-data          4:5.2.0-2
ii  digikam-private-libs  4:5.2.0-2
ii  libc6                 2.24-5
ii  libgcc1               1:6.2.0-9
ii  libkf5configcore5     5.27.0-1
ii  libkf5coreaddons5     5.27.0-1
ii  libkf5filemetadata3   5.27.0-1
ii  libkf5i18n5           5.27.0-2
ii  libqt5core5a          5.6.1+dfsg-3+b1
ii  libqt5gui5            5.6.1+dfsg-3+b1
ii  libqt5sql5            5.6.1+dfsg-3+b1
ii  libqt5sql5-mysql      5.6.1+dfsg-3+b1
ii  libqt5sql5-sqlite     5.6.1+dfsg-3+b1
ii  libqt5widgets5        5.6.1+dfsg-3+b1
ii  libstdc++6            6.2.0-9
pn  perl:any              <none>

Versions of packages digikam recommends:
ii  chromium [www-browser]              53.0.2785.143-1
ii  ffmpegthumbs                        4:16.08.0-1
ii  firefox [www-browser]               49.0-4
ii  google-chrome-stable [www-browser]  54.0.2840.71-1
ii  konqueror [www-browser]             4:16.08.2-1
ii  w3m [www-browser]                   0.5.3-31

Versions of packages digikam suggests:
pn  digikam-doc     <none>
ii  systemsettings  4:5.8.2-1

-- no debconf information

_______________________________________________
pkg-kde-extras mailing list
pkg-kde-extras@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-kde-extras

Reply via email to