Hi,

I created a patch for amarok that switches to using mariadb. I don't see how 
the current mysql-defaults system can be used in amarok, as there is no 
default-mysqld-dev package.

$ diff -u debian.orig/amarok-2.8.0/debian/control 
debian/amarok-2.8.0/debian/control
--- debian.orig/amarok-2.8.0/debian/control     2016-12-01 20:16:40.000000000 
+0100
+++ debian/amarok-2.8.0/debian/control  2016-12-15 20:26:31.791265529 +0100
@@ -11,12 +11,12 @@
  kdelibs5-dev (>= 4:4.8.4),
  libmtp-dev (>= 1.0.0), libqjson-dev,
  libglib2.0-dev, libgpod-nogtk-dev (>= 0.7.0) | libgpod-dev (>= 0.7.0),
- libmysqld-pic (>= 5.5.23+dfsg), libwrap0-dev,
+ libmariadbd-dev, libwrap0-dev,
  libcurl4-gnutls-dev, libxml2-dev, libloudmouth1-dev,
  libgtk2.0-dev, libqca2-dev, liblastfm-dev (>= 1.0.3),
  libavformat-dev (>= 4:0.5), libofa0-dev, libaio-dev [linux-any],
  libgcrypt20-dev
-Build-Depends-Indep: mysql-server-core-5.6 | virtual-mysql-server-core
+Build-Depends-Indep: mariadb-server-core-10.0 | virtual-mysql-server-core
 Standards-Version: 3.9.8
 Homepage: http://amarok.kde.org
 Vcs-Git: https://anonscm.debian.org/git/pkg-kde/kde-extras/amarok.git

I compile tested the patch in pbuilder and tested the resulting .debs on my 
system.

It would be great If this could get reviewed and if acceptable uploaded to 
unstable so we can get an amarok in stretch.

Thanks,
Maxi

Attachment: signature.asc
Description: This is a digitally signed message part.

_______________________________________________
pkg-kde-extras mailing list
pkg-kde-extras@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-kde-extras

Reply via email to