Package: kile
Version: 4:2.9.91-3
Severity: normal

Dear Maintainer,

If the okular package is not installed, kile can not start and crashes on a
segmentation fault.

Manually installing the okular package fixes the problem, so it should probably
be added to the dependencies.

>From a quick debug session in the code, I saw that the code tries deferencing
the m_livePreviewManager pointer but that pointer was previously deleted.



-- System Information:
Debian Release: buster/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (500, 'stable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.14.0-2-amd64 (SMP w/4 CPU cores)
Locale: LANG=it_IT.UTF-8, LC_CTYPE=it_IT.UTF-8 (charmap=UTF-8), LANGUAGE= 
(charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages kile depends on:
ii  kio                    5.37.0-2
ii  konsole-kpart          4:17.08.3-1
ii  libc6                  2.26-2
ii  libgcc1                1:7.2.0-19
ii  libkf5codecs5          5.37.0-2
ii  libkf5completion5      5.37.0-2
ii  libkf5configcore5      5.37.0-2
ii  libkf5configgui5       5.37.0-2
ii  libkf5configwidgets5   5.37.0-2
ii  libkf5coreaddons5      5.37.0-2
ii  libkf5dbusaddons5      5.37.0-2
ii  libkf5guiaddons5       5.37.0-2
ii  libkf5i18n5            5.37.0-2
ii  libkf5iconthemes5      5.37.0-2
ii  libkf5jobwidgets5      5.37.0-2
ii  libkf5khtml5           5.37.0-3
ii  libkf5kiocore5         5.37.0-2
ii  libkf5kiofilewidgets5  5.37.0-2
ii  libkf5kiowidgets5      5.37.0-2
ii  libkf5parts5           5.37.0-2
ii  libkf5service-bin      5.37.0-2
ii  libkf5service5         5.37.0-2
ii  libkf5texteditor5      5.37.0-2+b1
ii  libkf5textwidgets5     5.37.0-2
ii  libkf5widgetsaddons5   5.37.0-2
ii  libkf5windowsystem5    5.37.0-2
ii  libkf5xmlgui5          5.37.0-2
ii  libpoppler-qt5-1       0.61.1-2
ii  libqt5core5a           5.9.2+dfsg-6
ii  libqt5dbus5            5.9.2+dfsg-6
ii  libqt5gui5             5.9.2+dfsg-6
ii  libqt5script5          5.9.2+dfsg-2
ii  libqt5widgets5         5.9.2+dfsg-6
ii  libqt5xml5             5.9.2+dfsg-6
ii  libstdc++6             7.2.0-19
ii  perl                   5.26.1-3
ii  texlive-latex-base     2017.20180103-1

Versions of packages kile recommends:
ii  dvipng                           1.14-2+b3
ii  ghostscript                      9.22~dfsg-1
ii  imagemagick                      8:6.9.7.4+dfsg-16
ii  imagemagick-6.q16 [imagemagick]  8:6.9.7.4+dfsg-16
ii  psutils                          1.17.dfsg-4
ii  texlive                          2017.20180103-1

Versions of packages kile suggests:
ii  aspell                          0.60.7~20110707-4
pn  asymptote                       <none>
pn  context                         <none>
pn  dblatex                         <none>
ii  ispell                          3.4.00-6
pn  kbibtex                         <none>
pn  kile-doc                        <none>
pn  kile-l10n                       <none>
pn  latex2html                      <none>
ii  lilypond                        2.18.2-11
ii  texlive-plain-generic [tex4ht]  2017.20180103-2
pn  texlive-xetex                   <none>
ii  zip                             3.0-11+b1

-- no debconf information

_______________________________________________
pkg-kde-extras mailing list
pkg-kde-extras@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-kde-extras

Reply via email to