Hi!

You provided second build of KDE 4.0.80 for i386 but there is a problem with
amd64 arch. When you upgrade to 4.0.80-2 for i386 arch you also add
dependencies to packages for all architectures.

I know that I'm not well English speaker, so lets  go step by step instead
describing...
*
kdebase-workspace* has Architecture
all<http://packages.debian.org/experimental/all/kdebase-workspace/download>
*kdebase-workspace *has version 4.0.80-2 like i386 (this is problem because
because amd64 has only first build)
*kdebase-workspace *depends on:

   - dep: 
kde-window-manager<http://packages.debian.org/experimental/kde-window-manager>(>=
4:4.0.80-2) the
   KDE 4 window manager (KWin)
   - dep: 
kdebase-workspace-bin<http://packages.debian.org/experimental/kdebase-workspace-bin>(>=
4:4.0.80-2) core
   binaries for the KDE 4 base workspace module
   - dep: klipper <http://packages.debian.org/experimental/klipper> (>=
   4:4.0.80-2) clipboard utility for KDE 4
   - dep: ksysguard <http://packages.debian.org/experimental/ksysguard> (>=
   4:4.0.80-2) System Guard for KDE 4
   - dep: 
systemsettings<http://packages.debian.org/experimental/systemsettings>(>=
4:4.0.80-2) KDE
   4 System Settings

but version from:
http://ftp.de.debian.org/debian/pool/main/k/kdebase-workspace/kdebase-workspace_4.0.80-1_all.deb
depends on (these dependencies are good for amd64 build):

   - dep: 
kde-window-manager<http://packages.debian.org/experimental/kde-window-manager>(>=
4:4.0.80-1) the
   KDE 4 window manager (KWin)
   - dep: 
kdebase-workspace-bin<http://packages.debian.org/experimental/kdebase-workspace-bin>(>=
4:4.0.80-1) core
   binaries for the KDE 4 base workspace module
   - dep: klipper <http://packages.debian.org/experimental/klipper> (>=
   4:4.0.80-1) clipboard utility for KDE 4
   - dep: ksysguard <http://packages.debian.org/experimental/ksysguard> (>=
   4:4.0.80-1) System Guard for KDE 4
   - dep: 
systemsettings<http://packages.debian.org/experimental/systemsettings>(>=
4:4.0.80-1) KDE
   4 System Settings

So there are two possibilities:

   - change architecture of current build *kdebase-workspace *from all to
   i386 and copy first build as amd64 architecture.
   - make second build KDE 4:4.0.80-2 for amd64 too
   - or something else

I hope that I was enough clearly.

I try all from downloading file by file and dpkg -i --force-depends
'package'  (not works because then apt says unsolved dependencies nad I have
to remove all the packages) to removing all kde and reinstalling, but
nothing worked.

Please hurry, I must suffer on GNOME now :( :D.


-- 
Lep pozdrav, Miha
Best regards, Miha
-- 
http://lists.alioth.debian.org/mailman/listinfo/pkg-kde-talk

Reply via email to