On Mon, Sep 29, 2008 at 12:29:32PM -0700, Anjum Kaiser wrote:
> Hi,
> 
> I'm getting this error while building kdemultimedia-4.1.1:
> 
> 
> In file included from 
> /build/apt-build/build/kdemultimedia-4.1.1/kioslave/audiocd/audiocd.cpp:30:
> /usr/include/cdda_interface.h:98: error: expected unqualified-id before 
> âprivateâ
> /usr/include/cdda_interface.h:98: error: expected â;â before âprivateâ
> /build/apt-build/build/kdemultimedia-4.1.1/kioslave/audiocd/audiocd.cpp: In 
> member function âcdrom_drive* AudioCD::AudioCDProtocol::initRequest(const 
> KUrl&)â:
> /build/apt-build/build/kdemultimedia-4.1.1/kioslave/audiocd/audiocd.cpp:224: 
> error: âstruct cdrom_driveâ has no member named âdevâ
> /build/apt-build/build/kdemultimedia-4.1.1/kioslave/audiocd/audiocd.cpp:235: 
> error: âstruct cdrom_driveâ has no member named âdevâ
> /build/apt-build/build/kdemultimedia-4.1.1/kioslave/audiocd/audiocd.cpp:237: 
> error: âstruct cdrom_driveâ has no member named âdevâ
> /build/apt-build/build/kdemultimedia-4.1.1/kioslave/audiocd/audiocd.cpp:246: 
> error: âstruct cdrom_driveâ has no member named âdevâ
> /build/apt-build/build/kdemultimedia-4.1.1/kioslave/audiocd/audiocd.cpp:247: 
> error: âstruct cdrom_driveâ has no member named âdevâ
> make[3]: *** [kioslave/audiocd/CMakeFiles/kio_audiocd.dir/audiocd.o] Error 1
> 
> any idea?
>
It is due new cdparanoia 10.2 in unstable, first problem is fixed with this
patch (it is made for 4.1.1 but should work):
http://svn.debian.org/wsvn/pkg-kde/branches/kde4/packages/kdemultimedia/debian/patches/10_r865240_cdparanoia.diff?op=file&rev=12266&sc=1

I still have not fixed the second one.

You can build against cdparanoia in testing and it will work fine.

Ana


-- 
http://lists.alioth.debian.org/mailman/listinfo/pkg-kde-talk

Reply via email to