as was discussed this afernoon (GMT+1) on IRC, we have no clear consensus on
binary package names for KDE Configuration Modules, mainly because we don't
have many packages of that sort yet. The question arises because there is an
ITP on kcm-touchpad (#568040).
I think that such a consensus is a good thing, even if not absolutely
==== What we have now ====
system-config-gtk-kde (src: gtk-qt-engine)
system-config-printer-kde (src: kdeadmin)
The "KDE System Configuration" binary is in the
systemsettings (src: kdebase-workspace)
And I think that's mostly it.
==== Options ====
We have discussed those four options (there are certainly more):
==== Pros and cons ====
+ Is already in the archive, down to Squeeze
+ Is pretty explicit
- was mostly pushed by myself, with no real consensus
- pollutes the system-config-* namespace, originally used for
RedHat utilities, which have then been ported to KDE (thus the
+ Already in use by other distros (OpenSuse, Ubuntu, …)
- Not really explicit
- Might become really long
+ Explicit, even if slightly less than the latter
==== My opinion (if that matters…) ===
I am now in favor of changing our actual packages to d) (kde-config-*), but
I am of course open to discussion. And for what matters, I really find b)
I also note that this could lead to a renaming of systemsettings to the "no-
wildcard" version of the naming scheme we could now choose.
===== Conclusion ===
So what is your opinion ?
Best regards and thanks for reading so far.