In kdenetwork we build a separate kopete-gcall package for the GTalk call 
feature.

kdenetwork (4:4.5.2-0ubuntu1) natty; urgency=low
  * Merge with Debian git remaining changes:
    - debian/control:
      - Build against libboost1.42-dev
      - Don't build against libkwebkit-dev (Universe):
      - Build against libexpat1-dev instead of libexpat-dev
      - libkopete4 suggests libjasper-runtime instead of recommends
      - kopete recommends kopete-message-indicator
      - kopete suggests kopete-gcall
      - kdenetworks metapackage depends on kpp
      - kdenetwork-filesharing depends on perl-suid
      - Add kopete-gcall package
    - debian/libkopete-dev.install
      - Add usr/lib/libkopete_videodevice.so
    - debian/rules:
      - chown kppp to root:dialout instead of root:dip
    - debian/not-installed: don't add usr/lib/libkopete_videodevice.so
    - debian/krdc.install: don't add
      
usr/share/dbus-1/services/org.freedesktop.Telepathy.Client.krdc_rfb_approver.service
      
usr/share/dbus-1/services/org.freedesktop.Telepathy.Client.krdc_rfb_handler.service
    - debian/kopete.install: don't add usr/bin/googletalk-call
    - Keep our patches
    - Build against kdelibs5-dev 4.5.2-0ubuntu1 for libkutils4
  transition

In kdeplasma-addons we build plasma-widget-kdeobservatory,
plasma-widget-kimpanel, plasma-widget-kimpanel-backend-ibus but not
plasma-widget-kimpanel-backend-scim. plasma-wallpapers-addons depends
on plasma-dataengines-workspace, kdewallpapers,
kdebase-workspace-wallpaper.  debian/xinput/ibus-kde script added for
ibus support.

kdeplasma-addons (4:4.5.2-0ubuntu1) natty; urgency=low
  * Merge with Debian git remaining changes:
    - Keep our patch
    - Add debian/xinput folder
    - Build plasma-widget-kdeobservatory, plasma-widget-kimpanel,
      plasma-widget-kimpanel-backend-ibus
    - Keep plasma-widget-kimpanel-backend-scim package commented
    - Keep rules to install plasma-widget-kimpanel-backend-ibus
    - Keep plasma-widget-kimpanel-backend-ibus.{postinst, prerm}
    - Don't install kimpanel in plasma-widget-addons
    - Build against libboost1.42-dev
    - plasma-wallpapers-addons depends on
  plasma-dataengines-workspace,
      kdewallpapers, kdebase-workspace-wallpapers
    - plasma-widget-addons suggests plasma-widget-lancelot instead of
      recommends
    - plasma-dataengines-addons replaces kdeplasma-addons (<<
  4:4.4.60) and
      plasma-widget-addons (<< 4:4.4.60)
    - Build against kdelibs5-dev 4.5.2-0ubuntu1 for libkutils4
  transition
    - Add libxml2-dev to build-dependencies

nothing much interesting in kdesdk

kdesdk (4:4.5.2-0ubuntu1) natty; urgency=low
  * Merge with Debian git remaining changes:
    - Build against libboost1.42-dev
    - kdesdk-dbg depends on kdesdk, not suggests
    - kdesdk-scripts suggests optipng and advancecomp, not recommends
    - Don't install the following files in kdesdk-scripts:
      - extractattr
      - extractrc
    - Keep our patches
    - kubuntu_01_kate_desktop.patch     kubuntu_03_optimizegraphics.diff

kdetoys has kweather.install removed

kdetoys (4:4.5.3-0ubuntu1) natty; urgency=low
  * Merge with Debian git remaining changes:
    - Don't add kweather.install (kweather is not distributed)

kdeutils adds some build-depends needed for ark. kdelirc  is now kremotecontrol

kdeutils (4:4.5.2-0ubuntu1) natty; urgency=low
  * Merge with Debian git remaining changes:
    - Add  libzip-dev, shared-desktop-ontologies, shared-mime-info,
      libqjson-dev, python-2.6 to build-dependencies
    - Add utilities-file-archiver.xpm icon needed by ark
    - Don't add libkvm-dev (not in archive)
    - Add kdelirc, printer-applet to kdeutils metapackage
    - ark suggests  bzip2, p7zip-full, zip, unzip, not recommends
    - ark does not support CD images - fix description
    - Keep our more verbose description for printer-applet and keep
  our
      depends
    - kdelirc package is replaced by kremotecontrol in KDE SC 4.5
    - Build against kdelibs5-dev 4.5.2-0ubuntu1 for libkutils4
  transition

Nothing significant in kdewebdev

We have a separate plasma-scriptengine-googlegadgets package for
archive reasons

kde-l10n is split up into one source package for each language to
match upstream.

Jonathan

--
http://lists.alioth.debian.org/mailman/listinfo/pkg-kde-talk

Reply via email to