Package: release.debian.org
Severity: normal
User: release.debian....@packages.debian.org
Usertags: unblock

Hi,

I would like to upload soprano 2.7.6+dfsg.1-2 with the following two
changes:
- add breaks/replaces in libsoprano-doc for the move of soprano.tag
  in an older version
- fix epoch in the version of the libqt4-dev build dependency

Attached the current diff out of the packaging repo of the changes
above.

Thanks,
-- 
Pino
diff --git a/debian/changelog b/debian/changelog
index 2f18bcf..f18a2ab 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+soprano (2.7.6+dfsg.1-2) UNRELEASED; urgency=low
+
+  [ Pino Toscano ]
+  * soprano.tag moved in since 2.6.0+dfsg.1-1 from libsoprano-dev to
+    libsoprano-doc, so add proper breaks/replaces. (Closes: #694288)
+  * Fix epoch in the version of the libqt4-dev build dependency.
+
+ -- Debian Qt/KDE Maintainers <debian-qt-...@lists.debian.org>  Sun, 25 Nov 2012 10:50:29 +0100
+
 soprano (2.7.6+dfsg.1-1) unstable; urgency=low
 
   * Team upload.
diff --git a/debian/control b/debian/control
index 6864c40..befe3a6 100644
--- a/debian/control
+++ b/debian/control
@@ -4,7 +4,7 @@ Priority: optional
 Maintainer: Debian Qt/KDE Maintainers <debian-qt-...@lists.debian.org>
 Uploaders: Sune Vuorela <deb...@pusling.com>, Fathi Boudra <f...@debian.org>, Modestas Vainius <mo...@debian.org>
 Build-Depends: debhelper (>= 7.4.15), cmake (>= 2.6.2), pkg-kde-tools (>= 0.12),
- dpkg-dev (>= 1.15.5), libclucene-dev (>= 0.9.21b), libqt4-dev (>= 4.5.3),
+ dpkg-dev (>= 1.15.5), libclucene-dev (>= 0.9.21b), libqt4-dev (>= 4:4.5.3),
  libraptor1-dev (>= 1.4.16), librdf0-dev (>= 1.0.13),
  doxygen (>= 1.7.1), graphviz, libiodbc2-dev
 Standards-Version: 3.9.3
@@ -70,6 +70,8 @@ Section: doc
 Architecture: all
 Depends: ${misc:Depends}
 Recommends: qt4-doc
+Breaks: libsoprano-dev (<< 2.6.0+dfsg.1-1)
+Replaces: libsoprano-dev (<< 2.6.0+dfsg.1-1)
 Description: developer documentation for the Soprano RDF framework
  Soprano is a pluggable RDF storage, parsing, and serialization framework based
  on Qt 4.  Soprano is targeted at desktop applications that need to store RDF
-- 
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-kde-talk

Reply via email to