On Sun, Mar 30, 2014 at 7:48 AM, Lisandro Damián Nicanor Pérez
> I'm so proposing to change the original naming scheme to:
> Where $module-name will be the lower-cased path replacing slashes with '-'.
> $QT_INSTALL_QML/foo/var/ would be packaged as qml-module-foo-var
> $QT_INSTALL_QML/foo/var.2/ would be packaged as qml-module-foo-var2
> $QT_INSTALL_QML/foo.2/var/ would be packaged as qml-module-foo2-var
> $QT_INSTALL_QML/foo2/var.2/ would be packaged as qml-module-foo2-var2
> What do you think of this? I plan to start packaging stuff (with the
> transitional packages required) either for 5.2.1 as soon as the transition
> finishes (we are almomst there) or for 5.3.0.
QtQuick1 is deprecated and not much matters, so I don't think we
should rename things just to prevent people from being confused by it.
But, anyway, your new package names are shorter (10-chars qml-module
vs 14-chars qtdeclarative5) and look nice, so I am fine with the