On Tuesday 09 September 2014 19:27:11 Lisandro Damián Nicanor Pérez Meyer 
wrote:
> On Tuesday 09 September 2014 20:19:29 Steven Chamberlain wrote:
> > Having touched Source/WTF/WTF.pri, I'm now stuck at this qmake error:
> > > cd Source/ && make -f Makefile.QtWebKit qmake_all
> > > make[4]: Entering directory `«PKGBUILDDIR»/WebKitBuild/Release/Source'
> > > /usr/lib/x86_64-kfreebsd-gnu/qt5/bin/qmake «PKGBUILDDIR»/Source/api.pri
> > > CONFIG+=no_force_sse2 CONFIG+=release CONFIG-=debug
> > > CONFIG+=production_build -o Makefile.api Project ERROR: Module does not
> > > define version.
> > 
> > Is it trying to regenerate makefiles because I've changed something
> > they're generated from?  But if I revert my change, it still does this.
> > Does that imply some pre-existing problem in the build process...
> > perhaps?  *sad, confused*
> 
> It's a quite hacked build system. I'll try in a clean build ASAP. I have
> also been pointed out that upstream might be able to take a look at this.
> 
> Thanks *a lot* Steve for this :)

Just set up a fresh VM with KFreeBSD-amd64 and using the previously suggested 
patch [1] worked for me to fix the build, see log [2].

Cheers,
Andreas

[1] http://homepages.upb.de/phoenixx/0001-Fix-build-on-KFreeBSD.patch
[2] http://homepages.upb.de/phoenixx/kfreebsd-build.tar.gz

PS: My setup slightly more verbose:
* KFreeBSD installed from current Debian/SID to VirtualBox
* got qtwebkit sources with "apt-get source"
* applied patches with "quilt push -a"
* used "dpkg-buildpackage -b"

-- 
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-kde-talk

Reply via email to