Hello,

Could the qt-at-spi package be depended on by e.g. libqtcore4?

At the moment, we made orca explictly depend on qt-at-spi (through
python-atspi), so that it is sure that it can read Qt4 applications. But
that means that Qt libraries get pulled on gnome-only desktop too,
which they don't want. Ideally a gnome-only desktop would not have
Qt libraries and not qt-at-spi either, and whenever installing a Qt4
application (e.g. virtualbox), qt-at-spi would get installed along the
Qt4 libraries, so orca can read it. The simplest way would be to just
make Qt4 depend on it, just like Qt5 ships the accessibility bridge
itself.

Samuel

-- 
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-kde-talk

Reply via email to