Lisandro Damián Nicanor Pérez Meyer, on Sat 14 Nov 2015 14:28:53 -0300, wrote:
> On Sunday 18 October 2015 18:19:01 Sune Vuorela wrote:
> > On Sunday 18 October 2015 17:24:59 Samuel Thibault wrote:
> > > Hello,
> > > 
> > > Could the qt-at-spi package be depended on by e.g. libqtcore4?
> > 
> > Hi
> > 
> > I guess one could put in a suggests somewhere, or maybe even a recommends,
> > but having it as a dependency would be making a dependency circle which I
> > really would like to avoid.
> > 
> > qt-at-spi depends itself on libqtcore4, as well as libkdecore5, libqt4-dbus
> > and libqtgui4
> 
> As long as it depends on kde stuff I can only put it on Suggest (which I did) 
> on libqtcore4. Any higher dependency would make normal installations pull KDE 
> stuff by default, which is definitely not good.

Err, only libkdecore5 and a couple of qt libraries: libqt4-dbus (already
needed for qt-at-spi), libqt4-network. Is that *really* a problem? We're
here talking about a bunch of MiB used on the disk.

Samuel

-- 
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-kde-talk

Reply via email to