On Thursday 07 January 2016 19:59:30 Dmitry Shachnev wrote:
> Hi,
> As you already know, in Qt 5.6 there was a change in ELF versions, from
> @Base to @Qt_5. I have developed a script for that (migrate-symbols.py)
> that scans the build log and updates the symbols files accordingly. That
> script changed the ELF version tags, but it did not touch the package
> version numbers.
> Now I have a bug: qttools5-dev-tools dependency on libqt5help5 is not
> enough: it depends on libqt5help5 (>= 5.0.2), however fails to work with
> 5.5:
> /usr/lib/x86_64-linux-gnu/qt5/bin/qhelpgenerator:
> /usr/lib/x86_64-linux-gnu/libQt5Help.so.5: version `Qt_5' not found
> (required by /usr/lib/x86_64-linux-gnu/qt5/bin/qhelpgenerator)
> How can I make sure a proper dependency is generated?

Build-Depends-Package from deb-symbols(5) possibly. That's what I wanted to 
add to qtbase, but you where faster than I to package it and then I forgot 
about it.

Una sola bomba nuclear puede arruinar el resto de tu día.

Lisandro Damián Nicanor Pérez Meyer

Attachment: signature.asc
Description: This is a digitally signed message part.


Reply via email to