On Thursday 07 January 2016 19:59:30 Dmitry Shachnev wrote:
> Hi,
> 
> As you already know, in Qt 5.6 there was a change in ELF versions, from
> @Base to @Qt_5. I have developed a script for that (migrate-symbols.py)
> that scans the build log and updates the symbols files accordingly. That
> script changed the ELF version tags, but it did not touch the package
> version numbers.
> 
> Now I have a bug: qttools5-dev-tools dependency on libqt5help5 is not
> enough: it depends on libqt5help5 (>= 5.0.2), however fails to work with
> 5.5:
> 
> /usr/lib/x86_64-linux-gnu/qt5/bin/qhelpgenerator:
> /usr/lib/x86_64-linux-gnu/libQt5Help.so.5: version `Qt_5' not found
> (required by /usr/lib/x86_64-linux-gnu/qt5/bin/qhelpgenerator)

Now the real interesting thing is that I built qtbase 5.6 and run apps built 
against qtbase 5.5 without issues :-/


-- 
Sea estricto cuando envíe y tolerante cuando reciba. En otras palabras, solo
envíe paquetes que cumplan rigurosamente con lo estándares, pero espere
paquetes que tal vez no cumplan del todo y trate de lidiar con ellos.
  Andrew S. Tanenbaum, de su libro "Computer Networks"

Lisandro Damián Nicanor Pérez Meyer
http://perezmeyer.com.ar/
http://perezmeyer.blogspot.com/

Attachment: signature.asc
Description: This is a digitally signed message part.

-- 
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-kde-talk

Reply via email to