On Thursday 07 January 2016 21:18:16 Pino Toscano wrote:
> In data giovedì 7 gennaio 2016 22:49:24, Dmitry Shachnev ha scritto:
> > Hi Pino,
> > 
> > On Thu, Jan 07, 2016 at 08:19:03PM +0100, Pino Toscano wrote:
> > > @Qt_5 symbols need to require version >= 5.6.0~beta, then: if not, the
> > > version filled in packages is not enough, causing runtime failures like
> > > the one you pasted above.
> > 
> > You mean I should bump the symbols versions, right?
> Yes.

Dmitry went this way already, so things should work now. Thanks Pino for 
helping us with this :)

Now on a different but related matter we still had doubts on why applications 
built with Qt 5.5 would work with Qt 5.6 even if the version nodes changed.

As described in [0]:

  "When the linker finds a symbol defined in a library which is not
   specifically bound to a version node, it will effectively bind it to an
   unspecified base version of the library."

So basically ld will link any app depending on the @Base version node to a lib 
that fullfils the symbol no matter it's version node, thus apps compiled 
against Qt << 5.6 will still work with Qt >= 5.6.

[0] <https://sourceware.org/binutils/docs/ld/VERSION.html>

All in all it was a very good idea to start packaging 5.6 during it's beta. 
Thanks everyone!

Outside of a dog, a book is man's best friend.
Inside of a dog, it's too dark to read.
 -- Groucho Marx

Lisandro Damián Nicanor Pérez Meyer

Attachment: signature.asc
Description: This is a digitally signed message part.


Reply via email to