Hi Sandro!

On Sun, Dec 25, 2016 at 02:14:12AM +0100, Sandro Knauß wrote:
> Hey,
>
> qtwebengine [0] entered sid today and unfortunately it failed for some archs.
> well it is one of those packages, that needs more than 4GB RAM/space for
> building. IMO I think the i386 build failed just because the buildd has not
> enough ram/space for the build. [1]

In qtwebkit we are using -Wl,--no-keep-memory [1]. Maybe it will help you too?
(Honestly I don't know why it is a patch and not a line in debian/rules.)

> For armel[2] i'm not sure what package I should add to build-deps:
> libc6-dev-armel-cross, libc6-dev-armhf-cross or libc6-dev, can you give me a 
> suggestion what to select?

You should not add any of these packages.

The compiler flags of the failing command -mfloat-abi=hard. It is a bug
in qtwebengine build system: on armel the float abi is soft, not hard.

[1] 
https://anonscm.debian.org/cgit/pkg-kde/qt/qt5webkit.git/tree/debian/patches/reduce_memory_usage.patch

--
Dmitry Shachnev

Attachment: signature.asc
Description: PGP signature

-- 
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-kde-talk

Reply via email to