On Tue, Jan 10, 2017 at 10:56:29AM +0000, Rik Mills wrote:
> 5.7.1+dfsg-3 fails to build on amd64 on ubuntu zesty with the following
> error
>
> any suggestions or resolution appreciated.
>
> https://launchpad.net/ubuntu/+source/qtwebengine-opensource-src/5.7.1+dfsg-3/+build/11834211

The difference between Ubuntu and Debian here is that Ubuntu amd64 builds
arch-indep + arch-amd64, while Debian amd64 buildds build only arch-amd64.

And because of parallelism override_dh_auto_install-arch removes the *.la
files, but then override_dh_auto_install-indep installs them again.

I think the attached patch should fix it, but not tested.

--
Dmitry Shachnev
diff --git a/debian/rules b/debian/rules
index 1ca6979..b09fe9a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -160,7 +160,6 @@ override_dh_auto_install-arch:
 	rm -fv debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/*.la
 
 override_dh_auto_install-indep:
-	dh_auto_install -i
 	dh_auto_build -- INSTALL_ROOT=$(CURDIR)/debian/tmp install_docs
 
 override_dh_install-arch:

Attachment: signature.asc
Description: PGP signature

-- 
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-kde-talk

Reply via email to