Your message dated Fri, 14 May 2010 13:58:38 +0200
with message-id <201005141358.38957.win...@der-winnie.de>
and subject line not meant for 2.6.32 kernel
has caused the Debian Bug report #581616,
regarding linux-patch-lustre: Patch fails to apply to current Debian kernel
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
581616: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=581616
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: linux-patch-lustre
Version: 1.8.2-1
Severity: grave
Justification: renders package unusable

Hi

This patch fails to apply to the current Debian kernel version, the series for 
2.6.32-vanilla is missing.


r...@ltest:/usr/src/kernel-patches/lustre/scripts# ./apply 
+ '[' -d kernel -a -d Documentation ']'
+ echo 'Not in kernel top level directory. Exiting'
Not in kernel top level directory. Exiting
+ exit 1
r...@dhcp-172-18-55-147:/usr/src/kernel-patches/lustre/scripts# cd 
/usr/src/linux-source-2.6.32
r...@dhcp-172-18-55-147:/usr/src/linux-source-2.6.32# 
/usr/src/kernel-patches/lustre/
patches/ scripts/ series/  
r...@dhcp-172-18-55-147:/usr/src/linux-source-2.6.32# 
/usr/src/kernel-patches/lustre/scripts/apply 
+ '[' -d kernel -a -d Documentation ']'
+ TOPPATCHDIR=/usr/src/kernel-patches/lustre
++ dpkg --print-installation-architecture
dpkg: warning: obsolete option '--print-installation-architecture', please use 
'--print-architecture' instead.
+ ARCHITECTURE=amd64
+ QUILT='quilt --quiltrc /dev/null'
+ export QUILT_PATCHES=/usr/src/kernel-patches/lustre/patches
+ QUILT_PATCHES=/usr/src/kernel-patches/lustre/patches
+ '[' -f debian/APPLIED_all_lustre ']'
++ sed -e 's/[^0-9]*\([0-9]*\)/\1/'
++ grep '^VERSION' Makefile
+ VERSION=2
++ sed -e 's/[^0-9]*\([0-9]*\)/\1/'
++ grep '^PATCHLEVEL' Makefile
+ PATCHLEVEL=6
++ sed -e 's/[^0-9]*\([0-9]*\)/\1/'
++ grep '^SUBLEVEL' Makefile
+ SUBLEVEL=32
+ KERNELRELEASE=2.6.32
+ mkdir -p debian/APPLIED_all_lustre_tmp
+ '[' -e series ']'
+ '[' -e .pc ']'
+ trap cleanup EXIT
+ echo Setting up quilt
Setting up quilt
+ quilt --quiltrc /dev/null setup 
/usr/src/kernel-patches/lustre/series/2.6.32-vanilla.series
+ ERR=0
+ '[' 0 = 0 ']'
+ echo Applying lustre patches
Applying lustre patches
+ quilt --quiltrc /dev/null push -a
No patches in series
+ ERR=2
+ '[' 2 = 0 ']'
+ echo Lustre patched failed to apply
Lustre patched failed to apply
+ echo Reverting partialy applied patch
Reverting partialy applied patch
+ quilt --quiltrc /dev/null pop -a
No patch removed
+ cleanup
+ echo Cleaning up
Cleaning up
+ '[' -e series ']'
+ '[' -e debian/APLLIED_all_lustre_tmp/series.orig ']'
+ '[' -e .pc ']'
+ '[' -e debian/APPLIED_all_lustre_tmp/.pc.orig ']'
+ exit 2
+ cleanup
+ echo Cleaning up
Cleaning up
+ '[' -e series ']'
+ '[' -e debian/APLLIED_all_lustre_tmp/series.orig ']'
+ '[' -e .pc ']'
+ '[' -e debian/APPLIED_all_lustre_tmp/.pc.orig ']'


-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-trunk-amd64 (SMP w/1 CPU core)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

linux-patch-lustre depends on no packages.

Versions of packages linux-patch-lustre recommends:
ii  kernel-package                12.033     A utility for building Linux kerne
ii  quilt                         0.48-7     Tool to work with series of patche

linux-patch-lustre suggests no packages.

-- no debconf information



--- End Message ---
--- Begin Message ---
Hey,

> This patch fails to apply to the current Debian kernel version, the series
> for 2.6.32-vanilla is missing.
Yes, it is missing because 2.6.32 is _not_ supported. This package is a very 
specialisied one, please don't use it if you doesn't know what you're doing 
there. 

Currently Oracle is not supporting any vanilla kernel, use for the kernel-
patch package a sles or rh kernel. We're working hard on porting it back to 
vanilla.

Greetings
winnie


--- End Message ---
_______________________________________________
Pkg-lustre-maintainers mailing list
Pkg-lustre-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-lustre-maintainers

Reply via email to