Your message dated Wed, 28 Jul 2010 11:50:39 +0000
with message-id <e1oe59j-0007iq...@franck.debian.org>
and subject line Bug#589230: fixed in lustre 1.8.3-3
has caused the Debian Bug report #589230,
regarding lustre-utils: possible FHS violation, as mkfs.lustre is not in /sbin
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
589230: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=589230
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: lustre-utils
Severity: serious
Justification: Policy 9.1.1

Hi.

I might have spotted a policy violation here (therefore the sevirity serious).

Policy section 9.1.1. specifies:
"The location of all installed files and directories must comply with the 
Filesystem Hierarchy
Standard (FHS), version 2.3, with the exceptions noted below,..."

The FHS in turn specifies:
"The following files, or symbolic links to files, must be in /sbin if the 
corresponding subsystem is installed:
...
fsck.*
mkfs.*
"
(see http://www.pathname.com/fhs/pub/fhs-2.3.html#SPECIFICOPTIONS8).


As far as I can tell this is not the case, right? 

I also do not see any exception for this in section 9.1.1.


I don't judge whether /sbin is really a better location,.... just wanted to 
bring this to your
attention :)


Cheers,
Chris.



--- End Message ---
--- Begin Message ---
Source: lustre
Source-Version: 1.8.3-3

We believe that the bug you reported is fixed in the latest version of
lustre, which is due to be installed in the Debian FTP archive:

liblustre_1.8.3-3_amd64.deb
  to main/l/lustre/liblustre_1.8.3-3_amd64.deb
linux-patch-lustre_1.8.3-3_all.deb
  to main/l/lustre/linux-patch-lustre_1.8.3-3_all.deb
lustre-dev_1.8.3-3_amd64.deb
  to main/l/lustre/lustre-dev_1.8.3-3_amd64.deb
lustre-source_1.8.3-3_all.deb
  to main/l/lustre/lustre-source_1.8.3-3_all.deb
lustre-tests_1.8.3-3_amd64.deb
  to main/l/lustre/lustre-tests_1.8.3-3_amd64.deb
lustre-utils_1.8.3-3_amd64.deb
  to main/l/lustre/lustre-utils_1.8.3-3_amd64.deb
lustre_1.8.3-3.diff.gz
  to main/l/lustre/lustre_1.8.3-3.diff.gz
lustre_1.8.3-3.dsc
  to main/l/lustre/lustre_1.8.3-3.dsc



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 589...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Patrick Winnertz <win...@debian.org> (supplier of updated lustre package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Wed, 28 Jul 2010 12:24:21 +0200
Source: lustre
Binary: linux-patch-lustre lustre-source lustre-utils lustre-tests liblustre 
lustre-dev
Architecture: source all amd64
Version: 1.8.3-3
Distribution: unstable
Urgency: low
Maintainer: Debian Lustre Packaging team 
<pkg-lustre-maintainers@lists.alioth.debian.org>
Changed-By: Patrick Winnertz <win...@debian.org>
Description: 
 liblustre  - Runtime library for Lustre filesystem utilities
 linux-patch-lustre - Linux kernel patch for the Lustre Filesystem
 lustre-dev - Development files for the Lustre filesystem
 lustre-source - source for Lustre filesystem client kernel modules
 lustre-tests - Test suite for the Lustre filesystem
 lustre-utils - Userspace utilities for the Lustre filesystem
Closes: 589230
Changes: 
 lustre (1.8.3-3) unstable; urgency=low
 .
   * [015b186] Fixed typo in bug15587 patch: SECURUTY --> SECURITY
   * [3f28bcb] Add a suggest to ofa-kernel-source and link against a ofa-
     kernel-headers dir if available
   * [912f1ee] Add a ugly hack to recommend ofa-kernel-modules if they
     should exist (if lustre is linked against it)
   * [5d01075] Install mkfs.lustre into /sbin instead of /usr/sbin
     (Closes: #589230)
Checksums-Sha1: 
 a9c70012eff2593500354073628ec7ba7fc1d170 1414 lustre_1.8.3-3.dsc
 b9538f0d4f01a2b42a260df199d84e39afca5a93 65782 lustre_1.8.3-3.diff.gz
 5a01202493dcf6b7153ada152479c20160f9f3b5 609738 
linux-patch-lustre_1.8.3-3_all.deb
 c7f18b38df8581e005d35eef21530490618da166 3726684 lustre-source_1.8.3-3_all.deb
 1f438f6fd157028d12d34d6dee968238738a81a3 745602 lustre-utils_1.8.3-3_amd64.deb
 963e43460262131111be62f57cf9e67d3c9dcb18 469476 lustre-tests_1.8.3-3_amd64.deb
 1e5b422ed63a6c0d61bc2b5423001910d3c2e562 5430772 lustre-dev_1.8.3-3_amd64.deb
 f3c6b51ba5840ce6892436cfed15b08edd42d576 862736 liblustre_1.8.3-3_amd64.deb
Checksums-Sha256: 
 58ac29b83e5226d6a06cb6a55836f8b893914087e057f08a08767a672e7bbf03 1414 
lustre_1.8.3-3.dsc
 646f4353d36b22f01d61f04984a294f3994f652860513a92b51eda74a541d987 65782 
lustre_1.8.3-3.diff.gz
 f7f9eac1dc02b04722d73f691c9d54ab387eec7d2d17994edf585446a619d2a7 609738 
linux-patch-lustre_1.8.3-3_all.deb
 c120c2e794b492e7f3adab147b149cc9cfd18ddc53a53f78084b008ac12ccbb9 3726684 
lustre-source_1.8.3-3_all.deb
 4cc58a10a223675683455c8999305b7264d339f6c17e2a72a0a784c80dabcd6b 745602 
lustre-utils_1.8.3-3_amd64.deb
 ac036074dd691d0ae45a5ee2d3b424a42133a93a8a62c1d3c81fba943064a632 469476 
lustre-tests_1.8.3-3_amd64.deb
 223c4b64a3d4da8876267245e80a27129910a3754f09260fbd04d295bf336245 5430772 
lustre-dev_1.8.3-3_amd64.deb
 d776caf0928107631262957a7b80265e3ac565d7279014d290a222b427ae8d02 862736 
liblustre_1.8.3-3_amd64.deb
Files: 
 a72b24073e6922cc02284243b064ffbd 1414 admin optional lustre_1.8.3-3.dsc
 37f3c248049f83d13805cc97d450fdfb 65782 admin optional lustre_1.8.3-3.diff.gz
 a83c89ea45a930aae4389c403c08d907 609738 kernel optional 
linux-patch-lustre_1.8.3-3_all.deb
 8ce0ee871c8dd6c0b0012f1f94b4a326 3726684 kernel optional 
lustre-source_1.8.3-3_all.deb
 548e6235d770566fec5a5932e81a8661 745602 utils optional 
lustre-utils_1.8.3-3_amd64.deb
 33d0ea2a787cd5bb9f7b0b4878e63f56 469476 admin optional 
lustre-tests_1.8.3-3_amd64.deb
 e33c3278c119be25463b53e5a06fcd9b 5430772 libdevel optional 
lustre-dev_1.8.3-3_amd64.deb
 87ee95ba739c873b9056f7c57c1d0a85 862736 otherosfs optional 
liblustre_1.8.3-3_amd64.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAkxQE8oACgkQzgm26bkTFDp+FQCfRuWdAhU33PymyfWDqPKVVCY1
PhwAoIG216yiAKSJBBQ0DzVwii53dKKL
=HMXo
-----END PGP SIGNATURE-----



--- End Message ---
_______________________________________________
Pkg-lustre-maintainers mailing list
Pkg-lustre-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-lustre-maintainers

Reply via email to