The following commit has been merged in the master branch:
commit b4b26cffb18b637c57ee92cadf85cfdb0d330ebe
Author: Patrick Winnertz <win...@debian.org>
Date:   Fri Mar 13 10:18:01 2009 +0100

    Build ldiskfsck and lfsck only on i386, amd64 and ia64 as it is not 
supposed to be used on powerpc (Closes: #511722)
    
    According to Andreas Dilger ldiskfsck can't build on powerpc as it is 
currently not supposed to build on big-endian machines
    
    Signed-off-by: Patrick Winnertz <win...@debian.org>

diff --git a/debian/control b/debian/control
index 88a8f62..0b251b8 100644
--- a/debian/control
+++ b/debian/control
@@ -3,14 +3,14 @@ Section: admin
 Priority: optional
 Maintainer: Debian Lustre Packaging Team 
<pkg-lustre-maintain...@lists.alioth.debian.org>
 Uploaders: Patrick Winnertz <win...@debian.org>, Noèl Köthe <n...@debian.org>
-Build-Depends: texi2html (>= 1.76), gettext, texinfo, dc, pkg-config, 
dietlibc-dev [alpha amd64 arm hppa i386 ia64 mips mipsel powerpc ppc64 s390 
sparc], libsepol1-dev [!hurd-i386 !kfreebsd-i386 !kfreebsd-amd64], 
libdevmapper-dev [!hurd-i386 !kfreebsd-i386 !kfreebsd-amd64], libselinux1-dev 
[!hurd-i386 !kfreebsd-i386 !kfreebsd-amd64], debhelper (>= 4), lustre-dev, 
libdb-dev (>= 4.4.20), quilt
+Build-Depends: texi2html (>= 1.76), gettext, texinfo, dc, pkg-config, 
dietlibc-dev, libsepol1-dev, libdevmapper-dev, libselinux1-dev, debhelper (>= 
4), lustre-dev, libdb-dev (>= 4.4.20), quilt
 Standards-Version: 3.8.0
 
 Package: ldiskfsck
 Section: admin
 Priority: optional
 Depends:
-Architecture: any
+Architecture: i386 amd64 ia64
 Description: statically-linked lustre version of the ext2 filesystem checker
  This binary is necessary in order to check the lustre filesystem on OST and
  MGS nodes. This binary is linked statically in order to do not conflict with
@@ -22,7 +22,7 @@ Package: lfsck
 Section: admin
 Priority: optional
 Depends:
-Architecture: any
+Architecture: i386 amd64 ia64
 Description: statically linked version of the lustre filesystem checker
  This binary is necessary to check the complete lustre filesystem for errors.
  You only need that package on lustre clients.

-- 
Repository for maintaining lidskfsprogs

_______________________________________________
Pkg-lustre-svn-commit mailing list
Pkg-lustre-svn-commit@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-lustre-svn-commit

Reply via email to