Your message dated Mon, 10 Mar 2014 23:48:46 +0000
with message-id <e1wn9w6-0006oq...@franck.debian.org>
and subject line Bug#740762: fixed in mozilla-devscripts 0.36
has caused the Debian Bug report #740762,
regarding xpi-repack: missing --upstream-version -> unhelpful error
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
740762: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=740762
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: mozilla-devscripts
Version: 0.35
Severity: minor

xpi-repack dies with an exception if you don't provide --upstream-version. It would be nice if could print a more meaningful error message.

$ xpi-repack moo.xpi
Traceback (most recent call last):
  File "/usr/bin/xpi-repack", line 132, in <module>
    main()
  File "/usr/bin/xpi-repack", line 129, in main
    repack_xpi(package, upstream_version, args[0], verbose)
  File "/usr/bin/xpi-repack", line 39, in repack_xpi
    extract_dir = package + "-" + upstream_version
TypeError: cannot concatenate 'str' and 'NoneType' objects

--
Jakub Wilk

--- End Message ---
--- Begin Message ---
Source: mozilla-devscripts
Source-Version: 0.36

We believe that the bug you reported is fixed in the latest version of
mozilla-devscripts, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 740...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Benjamin Drung <bdr...@debian.org> (supplier of updated mozilla-devscripts 
package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Tue, 11 Mar 2014 00:28:21 +0100
Source: mozilla-devscripts
Binary: mozilla-devscripts
Architecture: source all
Version: 0.36
Distribution: unstable
Urgency: medium
Maintainer: Debian Mozilla Extension Maintainers 
<pkg-mozext-maintainers@lists.alioth.debian.org>
Changed-By: Benjamin Drung <bdr...@debian.org>
Description: 
 mozilla-devscripts - Development scripts used by Mozilla's addons packages
Closes: 639917 740752 740759 740762
Changes: 
 mozilla-devscripts (0.36) unstable; urgency=medium
 .
   * xpi-repack:
     - Use argparse instead of getopts.
     - Use the tempfile module to create a secure temporary directory.
       Thanks to Jakub Wilk <jw...@debian.org> (Closes: #740759)
     - Print meaningful error message when --upstream-version is missing.
       (Closes: #740762)
     - Add --format option and document default compression format.
       (Closes: #639917)
   * xpi-unpack: Fix unpacke -> unpacked typo (Closes: #740752)
Checksums-Sha1: 
 be2503721766b539ffc6eb02f7991804afd4db06 1750 mozilla-devscripts_0.36.dsc
 c8b01a8bc2db302c7519c69ae9d301c414962c96 36260 mozilla-devscripts_0.36.tar.xz
 02f71f0ee04aeb256702813a8b6e99251bc7fde0 35436 mozilla-devscripts_0.36_all.deb
Checksums-Sha256: 
 10860949ecf5f1f606e486e170a91c0166abdd2ba537251d815385a6fdf549f9 1750 
mozilla-devscripts_0.36.dsc
 a8820f5689a28d8ee72fa4640e0ec9b4dd40c603976cba4885bfe948970e9d69 36260 
mozilla-devscripts_0.36.tar.xz
 56d4ba43ba53c3d845854bed0247525d40babcbc92da0df71d1a204acb28cdd7 35436 
mozilla-devscripts_0.36_all.deb
Files: 
 0f2b32a41c6f025a8f2ec0d2cc563301 1750 devel optional 
mozilla-devscripts_0.36.dsc
 884d2f56b95659bd3870caea12251dfc 36260 devel optional 
mozilla-devscripts_0.36.tar.xz
 da14fd3c1f29c5aab20d6be9aaee1761 35436 devel optional 
mozilla-devscripts_0.36_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIcBAEBCgAGBQJTHkxsAAoJEBWetcTvyHdMWfAP/Rfqk/lLIUcGBa8gQUWqQ366
1RiLvoOpz0dKrVfou1wW6hf49bNMAlw2mIEZEBXtTw0WJVaZH3Lhio3woO+Fk/M8
KkEHCD+yzAmzkMyMzD5/YMMCQmsGpbLl3xEoxTnXuZAa2vBr60gD5dlZP+IV5RXG
RNxfQ5xt43n3TypYZymEweNHmVuNppLv+7xGagt67pQffWDClwowiIwAIY82OJNd
4CmzimM8PnRIsXHxhIo7IYHsSAkLhRDpr9ji22mOYus9z+zH7/XX5gJGZV0g5sze
qt4u2YQLnhSaleohRpkznR1zgrFdwamNmGELWh/lMBGBHUIbBgEGio90NSIa+1Yn
viAwvwxMPMUpz2d1uWuhrQwBoR3jeXs3BPrq0ViOGElkIBeZH5cZrrgfS5VYRstT
YqMeuuqs7GfKnrliMebiYmZXDRGipfLBfAGGVtkjjddB8nBNIJCS54trUI6HrDph
cbiNyn5HXjsNGUFXbOl6k/l6hbL9HwedtUY709P2L7w2fYCKuzgNzNjUJi1q658x
y/g5zca4+SAAPvJX8V8NxQtkocmpRNspOp/uAAqdaKq6ZWIWPvMIG7W7vx7wZubg
O9UzPnVdakmn7W9bVl4wmyaUxs/NWgQs7RokyVBo6Xqcs7rr4HVgm2llps4UpcDn
Py5nOy/HCQw9ZHqxCBnJ
=5IzY
-----END PGP SIGNATURE-----

--- End Message ---
_______________________________________________
Pkg-mozext-maintainers mailing list
Pkg-mozext-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-mozext-maintainers

Reply via email to