Dear Maintainers,

The default Ruby version will soon be switched to version 2.0.

I'm mailing this notice to you because you're listed as the
maintainer of one or more packages Build-Depending on ruby or
ruby1.9.1, in the hope that you could test your package with
the new Ruby version and possibly fix it if it would break.

Packages FTBFS'ing already have a severity normal bug. These will
be raised in severity in due time.


What exactly will change?
-------------------------

ruby (src:ruby-defaults) will change it's dependencies and
symlinks from 1.9.1 to 2.0. Symlinks after the change:

  /usr/bin/erb -> erb2.0*
  /usr/bin/gem -> gem2.0*
  /usr/bin/irb -> irb2.0*
  /usr/bin/rdoc -> rdoc2.0*
  /usr/bin/ri -> ri2.0*
  /usr/bin/ruby -> ruby2.0*
  /usr/bin/testrb -> testrb2.0*


How can I test this today?
--------------------------

Install ruby (and ruby-dev, ruby-tcltk, and so on) from experimental.
The new version is 1:2.0.0.1~exp2.


What's new in Ruby 2.0?
-----------------------

See the Ruby 2.0 upstream release announcement:
https://www.ruby-lang.org/en/news/2013/02/24/ruby-2-0-0-p0-is-released/
The release announcement also has a short section on incompatible
changes. Most important changes:
 - iconv is gone
 - UTF-8 is now default on

There's also a slight change in Kernel#exec behaviour, see Debian bug
#740564 for details if you're using exec with fd redirection.

Nice slides talking mostly about new features:
https://speakerdeck.com/geeforr/whats-new-in-ruby-2-dot-0


Up next
-------

I've also sent this mail to maintainers currently Build-Depending on
ruby1.9.1, for a very good reason:
After switching to 2.0 as default, we'll try to remove 1.9.1.
As a further step, we'll have this entire migration again, but going
from 2.0 to 2.1 (and then removing 2.0).

Therefore, please move to (Build-)Depends: ruby((-all)-dev) if
possible, or if that is out of the question, to ruby2.0(-dev) when
the new ruby-defaults enters sid (and then again for 2.1).


How can I be of additional help?
--------------------------------

Please help fixing the FindRuby macro in cmake (see #730095), or any
of the existing FTBFS bugs:
https://bugs.debian.org/cgi-bin/pkgreport.cgi?tag=ruby-defaults-2.0;users=debian-r...@lists.debian.org


Where to get help
-----------------

Please see https://wiki.debian.org/Teams/Ruby


Thank you for your attention.

-- 
 ,''`.  Christian Hofstaedtler <z...@debian.org>
: :' :  Debian Developer
`. `'   7D1A CFFA D9E0 806C 9C4C  D392 5C13 D6DB 9305 2E03
  `-

Attachment: signature.asc
Description: Digital signature

_______________________________________________
Pkg-mozext-maintainers mailing list
Pkg-mozext-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-mozext-maintainers

Reply via email to