Package: release.debian.org
Severity: normal
Tags: wheezy
User: release.debian....@packages.debian.org
Usertags: pu

Hi,

As reported in #740539, the noscript version currently in stable does
not work properly with iceweasel 24 from stable-security. I’d like you
to consider accepting the (rebuilt in Wheezy) version currently
available in Jessie and Sid, known to work with iceweasel 24 and 17.

I’m happy to provide an actual debdiff, but given how insanely huge
those 4,2MB are, I’ll just inform you of the diffstat last line as a
start:

 451 files changed, 49402 insertions(+), 33998 deletions(-)

I’m sorry to ask for such a request again, but it seems like the less
ugly way to handle the new ESR-support of iceweasel in stable…

I just had to change the JavaScript compressor used at build time to
build the package in stable, so here is the debdiff against the unstable
version.

Thanks (a lot) in advance for considering.

Regards

David

P.-S.: As for firebug and sage-extension, the greasemonkey version from
unstable is not compatible with iceweasel 17, so I’m not yet bugging you
to accept a #739023 “fix” for this point release.

-- System Information:
Debian Release: jessie/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (500, 'stable'), (500, 
'oldstable'), (100, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.14-trunk-amd64 (SMP w/1 CPU core)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
diff -Nru mozilla-noscript-2.6.8.19/debian/changelog mozilla-noscript-2.6.8.19/debian/changelog
--- mozilla-noscript-2.6.8.19/debian/changelog	2014-03-30 16:52:40.000000000 -0400
+++ mozilla-noscript-2.6.8.19/debian/changelog	2014-04-13 18:25:32.000000000 -0400
@@ -1,3 +1,13 @@
+mozilla-noscript (2.6.8.19-1~deb7u1) wheezy; urgency=medium
+
+  * Team upload                               
+  * Use yui-compressor instead of node-uglify, since node-uglify is not
+    available in stable
+  * Upload compatible version with recent iceweasel to stable
+    (Closes: #740539)
+
+ -- David Prévot <taf...@debian.org>  Sun, 13 Apr 2014 18:24:37 -0400
+
 mozilla-noscript (2.6.8.19-1) unstable; urgency=medium
 
   * Team upload
diff -Nru mozilla-noscript-2.6.8.19/debian/control mozilla-noscript-2.6.8.19/debian/control
--- mozilla-noscript-2.6.8.19/debian/control	2014-03-30 16:07:46.000000000 -0400
+++ mozilla-noscript-2.6.8.19/debian/control	2014-04-13 18:22:00.000000000 -0400
@@ -3,7 +3,7 @@
 Priority: optional
 Maintainer: Debian Mozilla Extension Maintainers <pkg-mozext-maintainers@lists.alioth.debian.org>
 Uploaders: Damyan Ivanov <d...@debian.org>, Jérémy Bobbio <lu...@debian.org>
-Build-Depends: debhelper (>= 8), mozilla-devscripts, node-uglify
+Build-Depends: debhelper (>= 8), mozilla-devscripts, yui-compressor
 Standards-Version: 3.9.5
 Homepage: http://noscript.net/
 Vcs-Browser: http://anonscm.debian.org/gitweb/?p=pkg-mozext/noscript.git
diff -Nru mozilla-noscript-2.6.8.19/debian/rules mozilla-noscript-2.6.8.19/debian/rules
--- mozilla-noscript-2.6.8.19/debian/rules	2014-03-30 16:32:01.000000000 -0400
+++ mozilla-noscript-2.6.8.19/debian/rules	2014-04-13 18:22:22.000000000 -0400
@@ -3,7 +3,7 @@
 	dh $@ --with xul-ext --buildsystem=xul_ext --parallel
 
 override_dh_auto_build:
-	uglifyjs -o \
+	yui-compressor -o \
 		chrome/noscript.jar!/content/noscript/antlr.js \
 		debian/antlr3-all.js
 	dh_auto_build -O--buildsystem=xul_ext -O--parallel

Attachment: signature.asc
Description: Digital signature

_______________________________________________
Pkg-mozext-maintainers mailing list
Pkg-mozext-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-mozext-maintainers

Reply via email to