Hi Benjamin,

On Sat, May 10, 2014 at 11:33:17AM +0200, Benjamin Drung wrote:
> Am Freitag, den 09.05.2014, 21:03 -0400 schrieb David Prévot:
> > I am looking into updating reloadevery, and am surprised to see that the
> > following from install.rdf:
> > 
> >        <em:minVersion>24.*</em:minVersion>
> > 
> > is translated as:
> > 
> > xpi:Depends=iceweasel (>= 24.9223372036854775807)
> > […]
> > xpi:Breaks=iceweasel (<< 24.9223372036854775807)

>     "if the version part is a single asterisk, it is interpreted as an
>     infinitely-large number: 1.5.0.* is the same as 1.5.0.(infinity)"
> 
> Does reloadevery supports iceweasel 24 or not? How should
> mozilla-devscripts behave?

For this specific case, reloadevery seems to work fine in iceweasel 24,
so I’ll just patch install.rdf to make an upload to unstable, thanks for
the detailed information.

About mozilla-devscripts behaviour, maybe translating to something like:

xpi:Depends=iceweasel (>= 25~)
xpi:Breaks=iceweasel (<< 25~)

may be less suspicious, but I don’t feel strongly about it (maybe just
closing the bug as wontfix would be saner).

Please note that this behaviour can also be seen in xul-ext-greasemonkey
from experimental.

Regards

David

Attachment: signature.asc
Description: Digital signature

_______________________________________________
Pkg-mozext-maintainers mailing list
Pkg-mozext-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-mozext-maintainers

Reply via email to