Package: devscripts
Version: 2.14.2
Severity: normal
User: devscri...@packages.debian.org
Usertag: uscan

Downloading a Mozilla extension now fails with the following:

tabmixplus$ uscan --verbose --force
[…]
-- Downloading updated package tab_mix_plus-0.4.1.4pre.140414a1-fx.xpi
-- Checking for common possible upsteam OpenPGP signatures
Parameter ../tab_mix_plus-0.4.1.4pre.140414a1-fx.xpi does not look like a tar 
archive or a zip file. at /usr/bin/mk-origtargz line 315.
uscan: error: mk-origtargz --package tabmixplus --version 0.4.1.4~140414a1 
--compression gzip --directory .. --copyright-file debian/copyright 
../tab_mix_plus-0.4.1.4pre.140414a1-fx.xpi gave error exit status 25

The usual watch file looks like:

tabmixplus$ cat debian/watch 
version=3
options="uversionmangle=s/pre\./~/" \
https://ftp.mozilla.org/pub/mozilla.org/addons/1122/tab_mix_plus-([\d\.\w]+)-.*\.xpi
 debian xpi-repack

Regards

David

-- Package-specific info:

--- /etc/devscripts.conf ---

--- ~/.devscripts ---
DEBSIGN_KEYID=B82A217AFDFE09F2

-- System Information:
Debian Release: jessie/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (110, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.14-1-rt-amd64 (SMP w/2 CPU cores; PREEMPT)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages devscripts depends on:
ii  dpkg-dev     1.17.9
ii  libc6        2.18-6
ii  perl         5.18.2-4
ii  python3      3.3.4-1
pn  python3:any  <none>

Versions of packages devscripts recommends:
ii  at                          3.1.14-1
ii  curl                        7.36.0-2
ii  dctrl-tools                 2.23
ii  debian-keyring              2014.04.25
ii  dput                        0.9.6.4
ii  equivs                      2.0.9
ii  fakeroot                    1.20-3
ii  file                        1:5.18-1
ii  gnupg                       1.4.16-1.1
ii  libdistro-info-perl         0.13
ii  libencode-locale-perl       1.03-1
ii  libjson-perl                2.61-1
ii  liblwp-protocol-https-perl  6.04-3
ii  libparse-debcontrol-perl    2.005-4
ii  libsoap-lite-perl           1.11-1
ii  liburi-perl                 1.60-1
ii  libwww-perl                 6.06-1
ii  lintian                     2.5.22.1
ii  man-db                      2.6.7.1-1
ii  patch                       2.7.1-5
ii  patchutils                  0.3.3-1
ii  python3-debian              0.1.21+nmu3
ii  python3-magic               1:5.18-1
ii  sensible-utils              0.0.9
ii  strace                      4.5.20-2.3
ii  unzip                       6.0-12
ii  wdiff                       1.2.1-3
ii  wget                        1.15-1
ii  xz-utils                    5.1.1alpha+20120614-2

Versions of packages devscripts suggests:
ii  bsd-mailx [mailx]            8.1.2-0.20131005cvs-1
ii  build-essential              11.6
pn  cvs-buildpackage             <none>
pn  devscripts-el                <none>
ii  gnuplot                      4.6.5-1
ii  gpgv                         1.4.16-1.1
ii  libauthen-sasl-perl          2.1600-1
ii  libfile-desktopentry-perl    0.07-1
ii  libnet-smtp-ssl-perl         1.01-3
pn  libterm-size-perl            <none>
ii  libtimedate-perl             2.3000-2
ii  libyaml-syck-perl            1.27-2+b1
ii  mutt                         1.5.23-1
ii  openssh-client [ssh-client]  1:6.6p1-5
pn  svn-buildpackage             <none>
ii  w3m                          0.5.3-15

-- no debconf information

Attachment: signature.asc
Description: Digital signature

_______________________________________________
Pkg-mozext-maintainers mailing list
Pkg-mozext-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-mozext-maintainers

Reply via email to