On Wed, Jun 11, 2014 at 07:02:23PM +0200, Gabriele Giacone wrote:
> On Wed, Jun 11, 2014 at 11:41 AM, Mike Hommey <m...@glandium.org> wrote:
> > AFAICT, Ubuntu has a firefox-dev package that only contains NPAPI
> > headers in /usr/include/firefox. I don't think that would be enough for
> > all rdeps we have in Debian. I think some are not NPAPI plugins.
> >
> > Anyways, I guess most rdeps are just using the mozilla-*.pc files. I'll
> > at least add the mozilla-plugin.pc one in next upload (which I'll do
> > tomorrow morning, after I confirm only armel is broken). That should
> > help most.
> >
> >> How about linking /u/i/xulrunner -> /u/i/iceweasel-N instead?
> 
> Thanks, way cleaner.
> 
> >> BTW would packaging npapi-sdk still be a good alternative?
> >>
> >>   https://bugs.debian.org/642168
> >
> > Definitely, yes.
> 
> I've just uploaded it to mentors. Anyone interested in reviewing/sponsoring 
> it?
> 
> http://mentors.debian.net/package/npapi-sdk

You should install a mozilla-plugin.pc pkg-config file too. (and
conflict with xulrunner-dev as a consequence). That would allow packages
requiring the headers to build against that package instead of
xulrunner-dev without having to patch the source.

That said, the source you took seems outdated, and there are a few other
repos on github that have more recent headers. Also note the canonical
upstream is https://code.google.com/p/npapi-sdk/source/list (and r20 is
what the iceweasel source contains)

Cheers,

Mike

_______________________________________________
Pkg-mozext-maintainers mailing list
Pkg-mozext-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-mozext-maintainers

Reply via email to